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Thank you for purchasing your Topcon receiver, survey product or 
accessory (the “Product”). The materials available in this manual 
(the “Manual”) have been prepared by Topcon Positioning Systems, 
Inc. (“TPS”) for owners of Topcon products. This Manual is 
designed to assist owners with the use of software (the “Software”) 
to be used with the Product and its use is subject to these terms and 
conditions (the “Terms and Conditions”).

NOTICE
Please read these Terms and Conditions 
carefully.

Terms and Conditions
PROFESSIONAL USE – Topcon Products are designed to be used 
by a professional. The user is required to be a professional surveyor 
or have a good knowledge of surveying, in order to understand the 
user and safety instructions before operating, inspecting or 
adjusting. Always wear required safety attire (safety shoes, hard 
hat, etc.) when operating the Products.

COPYRIGHT – All information contained in this Manual is the 
intellectual property of, and copyrighted material of TPS. All rights 
are reserved. You may not use, access, copy, store, display, create 
derivative works of, sell, modify, publish, distribute, or allow any 
third party access to, any graphics, content, information or data in 
this Manual without the expressed written consent from TPS and 
may only use such information for the care and operation of your 
Product. The information and data in this Manual are a valuable 
 7010-0522 www.topconpositioning.com
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asset of TPS and are developed by the expenditure of considerable 
work, time and money, and are the result of original selection, 
coordination and arrangement by TPS.

TRADEMARKS – Topcon®, Topcon Link™, TopSURV™, and 
Topcon Positioning Systems™ are trademarks of TPS. Windows® 
and ActiveSync® are registered trademarks of Microsoft 
Corporation. Product and company names mentioned herein may be 
trademarks of their respective owners.

DISCLAIMER OF WARRANTY – EXCEPT FOR ANY 
WARRANTIES IN AN APPENDIX OR A WARRANTY CARD 
ACCOMPANYING THE PRODUCT, THIS MANUAL, THE 
PRODUCT, AND ANY ACCOMPANYING SOFTWARE ARE 
PROVIDED “AS-IS.” THERE ARE NO OTHER WARRANTIES. 
TPS DISCLAIMS ANY IMPLIED WARRANTY OF 
MERCHANTABILITY OR FITNESS FOR ANY PARTICULAR 
USE OR PURPOSE. TPS AND ITS DISTRIBUTORS SHALL 
NOT BE LIABLE FOR TECHNICAL OR EDITORIAL ERRORS 
OR OMISSIONS CONTAINED HEREIN; NOR FOR 
INCIDENTAL OR CONSEQUENTIAL DAMAGES RESULTING 
FROM THE FURNISHING, PERFORMANCE OR USE OF THIS 
MATERIAL, THE SOFTWARE, OR THE PRODUCT. SUCH 
DISCLAIMED DAMAGES INCLUDE, BUT ARE NOT 
LIMITED TO, LOSS OF TIME, LOSS OR DESTRUCTION OF 
DATA, LOSS OF PROFIT, SAVINGS OR REVENUE, OR LOSS 
OF THE PRODUCT’S USE. IN ADDITION, TPS IS NOT 
RESPONSIBLE OR LIABLE FOR DAMAGES OR COSTS 
INCURRED IN CONNECTION WITH OBTAINING 
SUBSTITUTE PRODUCTS OR SOFTWARE, CLAIMS BY 
OTHERS, INCONVENIENCE, OR ANY OTHER COSTS. IN 
ANY EVENT, TPS SHALL HAVE NO LIABILITY FOR 
DAMAGES OR OTHERWISE TO YOU OR ANY OTHER 
PERSON OR ENTITY IN EXCESS OF THE PURCHASE PRICE 
FOR THE PORDUCT. 
Topcon Topcon Link Reference Manual
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LICENSE AGREEMENT – Use of the Software and any other 
computer programs or software supplied by TPS or downloaded 
from a TPS website (the “Software”) to be used with a Topcon 
Product constitutes acceptance of these Terms and Conditions in 
this Manual and an agreement to abide by these Terms and 
Conditions. The user is granted a personal, non-exclusive, non-
transferable license to use such Software under the terms stated 
herein and in any case only with a single Product or single 
computer. You may make one (1) backup copy of the Software. 
Otherwise, the Software may not be copied or reproduced. You may 
not assign or transfer the Software or this license without the 
express written consent of TPS. This license is effective until 
terminated. You may terminate the license at any time by destroying 
the Software and Manual. TPS may terminate the license if you fail 
to comply with any of the Terms or Conditions. You agree to 
destroy the Software and manual upon termination of your use of 
the Product. All ownership, copyright and other intellectual 
property rights in and to the Software belong to TPS. If these 
license terms are not acceptable, return any unused Software and 
the Manual.

CONFIDENTIALITY – This Manual, its contents and the 
Software (collectively, the “Confidential Information”) are the 
confidential and proprietary information of TPS. You agree to treat 
TPS’ Confidential Information with a degree of care no less stringent 
than the degree of care you would use in safeguarding your own most 
valuable trade secrets. Nothing in this paragraph shall restrict you 
from disclosing Confidential Information to your employees as may 
be necessary or appropriate to operate or care for the Product. Such 
employees must also keep the Confidentiality Information 
confidential. In the event you become legally compelled to disclose 
any of the Confidential Information, you shall give TPS immediate 
notice so that it may seek a protective order or other appropriate 
remedy.
P/N 7010-0522 www.topconpositioning.com
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WEBSITE; OTHER STATEMENTS – No statement contained at 
the TPS website (or any other website) or in any other 
advertisements or TPS literature or made by an employee or 
independent contractor of TPS modifies these Terms and 
Conditions (including the Software License Agreement, Disclaimer 
of Warranty and limitation of liability). 

SAFETY – Improper use of a Topcon Product can lead to injury to 
persons or property and/or malfunction of the Product. The Product 
should only be repaired by authorized TPS warranty service 
centers. Users should review and heed the safety warnings in the 
manual accompanying the Product.

MISCELLANEOUS – The above Terms and Conditions may be 
amended, modified, superseded, or canceled, at any time by TPS. 
The above Terms and Conditions will be governed by, and 
construed in accordance with, the laws of the State of California, 
without reference to conflict of laws.
Topcon Topcon Link Reference Manual
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Manual Conventions
This manual uses the following conventions:

Example Explanation

File->Exit Click the File menu and click Exit.

Enter Indicates the button or key labeled Enter.

Topo Indicates the name of a dialog box or screen.

Notes Indicates a field on a dialog box or screen, or a tab 
within a dialog box or screen.

TIP
Supplementary information that can help you 
configure, maintain, or set up a system.

NOTICE
Supplementary information that can have an 
affect on system operation, system performance, 
measurements, personal safety.

CAUTION
Notification that an action has the potential to 
adversely affect system operation, system 
performance, data integrity, or personal 
health.
P/N 7010-0522 www.topconpositioning.com
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Topcon Link™ can be used to:

• Import files from Topcon Conventional Total Stations, Robotic 
Total Stations, a TPS Controller, and TPS GPS+ receivers to a 
computer.

• View and edit coordinate and raw data files.

• Reorganize coordinate and raw data files to files of the 
following formats:

• Create (make ready) and export coordinate files from a 
computer to a TPS Controller and/or a Total Station.

Table 1-1. Topcon Link File Formats

–TopSURV
–GIS (DXF, LandXML, Shape)
–Topcon TS Raw formats (GTS-6, 

GTS-7, GTS-7+, FC-5, 
GTS-210/310)

–Topcon TS Coordinate formats 
(GTS-7, FC-5, GTS-210/310-10, 
GTS-210/310-12)

–Char-delimited Coordinate formats 
(Name,Lat,Lon,Ht,Code; 
Name,N,E,Z,Code; 
Name,E,N,Z,Code; Custom)

–TSV ASCII Coordinate format
–TDS Coordinate format (CR5)
–RINEX
–TPS receiver data format (TPD)
–Topcon XML
–Topcon Geoid file
–Topcon GPS vector format
–Feature file
 7010-0522 www.topconpositioning.com
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Installing Topcon Link
Topcon Link software comes on a CD to install on a computer.

1. Insert the Topcon Link CD into the CD-ROM drive. The 
InstallShield® Wizard starts up.

2. Click Next on Topcon Link install Wizard dialog box to start 
the installation process.

3. Press Yes on the License Agreement dialog box (Figure 1-1). 
Clicking No terminates the installation.

Figure 1-1. License Agreement

4. On the Customer Information dialog box, enter the User and 
Company names, then click Next (Figure 1-2).

Figure 1-2. Enter Customer Information
Topcon Topcon Link Reference Manual
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5. On the Choose Destination Location dialog box, click Browse 
to select the folder or type a new folder name in which to install 
the Topcon Link. Click Next (Figure 1-3).

Figure 1-3. Choose Destination Location

6. On the Select Program Folder dialog box, select a current 
folder or type a new program folder name for Topcon Link 
(Figure 1-4). Then click Next.

Figure 1-4. Select Program Folder

The installation process starts.
P/N 7010-0522 www.topconpositioning.com
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7. Click Finish to exit the installation (Figure 1-5).

Figure 1-5. Installation Complete

8. Create a Topcon Link shortcut (Figure 1-6) on the computer 
desktop from which to quickly start the program.

Figure 1-6. Topcon Link Shortcut

Starting Topcon Link
To start Topcon Link, do one of the following:

• Click Start->Programs->Topcon->Topcon Link.

• Double-click the Topcon Link desktop shortcut.

The Topcon Link main window displays (see “Main Window” on 
page 1-5).
Topcon Topcon Link Reference Manual
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Getting Acquainted
This section introduces the various functions available in Topcon 
Link for viewing, configuring, or editing data files.

Main Window
The main window (Figure 1-7 on page 1-5) has the following 
components:

• Title bar – contains path information for job files.

• System buttons – the minimize, maximize, and close 
window buttons.

• Menu bar – contains drop-down menus for the various 
Topcon Tools functions.

• Toolbar – contains shortcut buttons to frequently used 
options.

• Work area – the area within which dialog boxes, job file 
information, and pop-up menus display.

• Status bar – displays informative messages about Topcon 
Tools and various files.

• File information – when a job file opens, displays 
applicable linear unit, angular unit, type of coordinate 
system, and coordinate system information.

Figure 1-7. Main Window Components

Work Area
P/N 7010-0522 www.topconpositioning.com
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Menu Bar
The menu bar provides access to most options available using 
Topcon Tools in six, clickable drop-down menus.

File Menu

The File menu (Figure 1-8):

• opens, saves, and closes a file;

• imports and exports data;

• converts a file from one format to another;

• prints information from an active file;

• displays job file configuration parameters;

• displays recently accessed files.

Figure 1-8. File Menu
Topcon Topcon Link Reference Manual
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Edit Menu

The Edit menu (Figure 1-9):

• allows a redo or undo of the last operation, or discards 
all changes;

• cuts, copies, pastes, or deletes information;

• displays the Properties dialog box.

Figure 1-9. Edit Menu

View Menu

The View menu (Figure 1-10) provides access to viewing 
and hiding the Toolbar and Status bar.

Figure 1-10. View Menu

Process Menu

The Process menu (Figure 1-11):

• computes coordinate;

• sets processing properties.

Figure 1-11. Process Menu
P/N 7010-0522 www.topconpositioning.com
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Window Menu

The Window menu (Figure 1-12):

• closes the current or all open windows;

• arranges open windows in a cascade (stacked) or tile 
(adjacent) views;

• arranges icons;

• indicates the current window.

Figure 1-12. Window Menu

Help Menu

The Help menu (Figure 1-13):

• provides context sensitive help and a help file;

• gives Topcon Link version and build date information.

Figure 1-13. Help Menu
Topcon Topcon Link Reference Manual
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Toolbar
The Toolbar for Topcon Link (Figure 1-14) contains buttons for 
frequently used functions.

Figure 1-14. Toolbar

Upon startup, the Toolbar displays beneath the menu bar. 

• To display or hide the Toolbar, click View->Toolbar. A 
check mark indicates the Toolbar is visible.

• To move the Toolbar menu, click the bar to the left of the 
Open icon, then drag the Toolbar to a new location and 
release the mouse button.

Table 1-2 lists and describes the various Toolbar icons.
Table 1-2. Toolbar Icon Functions

Icon Description

Open – Opens a file.
1. Click the button to display the Open dialog box.
2. Select the name of file and/or select a path or folder on the hard 

disk drive, local area network, or store media.
3. Click Open.

Save – Saves files to the current directory.

Import File from Device – Collects the observed files from TPS 
GPS+ receivers, TPS controller, and Conventional or Robotic Total 
Stations.
1. Click the button to display the Import file from device dialog box.
2. Select the device and click Next.
See “Importing Files” on page 2-1 for more details.

Export to Device – Exports data from files to a TPS controller or a 
Conventional or Robotic Total Station, and an Option Authorization 
File (OAF) to a TPS receiver.
1. Click the button to display the Export to Device dialog box.
2. Select the device and click Next.
See “Exporting Files” on page 2-15 for more details.
P/N 7010-0522 www.topconpositioning.com



Introduction

1-10
Convert Files – Displays the Convert File dialog box. See 
“Converting Files” on page 3-1 for more details.

Cut – Removes the marked area or text from the page, placing it on 
the Windows® clipboard. 

Copy – Copies text from the page, placing it on the Windows 
clipboard. 

Paste – Places selected text on the Windows clipboard.

Undo – Reverses the results.

Redo – Returns the results.

Compute Coordinates of Points – Computes (calculates) the 
coordinates of the points of the current file.

Print – Prints the current window or table.

About Topcon Tools – Displays the About Topcon Tools dialog box.

Table 1-2. Toolbar Icon Functions

Icon Description
Topcon Topcon Link Reference Manual
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This chapter describes importing and exporting, or transferring, 
files between devices and a computer using Topcon Link.

Importing Files
The following sections describe importing data files from a device, 
such as a Conventional/Robotic Total Station, a TPS GPS+ 
Receiver, or TPS Controller, to a computer.

1. To import files, do one of the following:

• Click File->Import from Device (Figure 2-1). 

Figure 2-1. File->Import From Device

• Press F7.

• Click the Import button on the Toolbar (Figure 2-2).

Figure 2-2. Import From Device – Toolbar Button
 7010-0522 www.topconpositioning.com
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The Import from Device dialog box displays (Figure 2-3). This 
dialog box consists of two panels.

• The upper panel displays icons of the four types of devices 
that provide raw data files for importing to Topcon Link. 
Initially, the previously chosen device is selected.

• The lower panel displays specific instructions for getting a 
device ready to import files.

Figure 2-3. Import From Device

• To open the imported file after completing the Import 
process, click and enable Open Files After Import.

• Right-clicking any device icon displays a pop-up menu 
from which you can (Figure 2-4 on page 2-3):

–Add a new device.

–Cut, copy, or delete a chosen device.

–Change an icon’s image.

–Set/change communication parameters.
Topcon Topcon Link Reference Manual
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Figure 2-4. Device Pop-up Menu

Adding Devices
1. To include a new device to the Import From Device list, 

right-click within the upper panel, click Add New Device 
from the pop-menu, then select the desired device type 
(Figure 2-5).

Figure 2-5. Import From Device – Pop-up Menu

2. On the Properties dialog box, enter the device name, 
comment, computer port, Total Station model (if 
applicable), and connection parameters (Figure 2-6 on 
page 2-4).
P/N 7010-0522 www.topconpositioning.com
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Figure 2-6. Properties Screens for Devices

3. Click Apply on each tab, then OK to set the properties of 
the new device and close the Properties dialog box.

Importing TPS Receiver Files
To import data from a TPS GPS+ receiver, follow the procedure 
below.

Set Communication Parameters

On the Import from Device dialog box set the correct 
communication parameters.

1. For the Topcon Link and TPS GPS+ receiver 
connection, right-click the TPS GPS+ receiver icon.

2. Click Properties on the pop-up menu.

3. Select the computer port (serial or USB) the receiver is 
connected to (Figure 2-7 on page 2-5).

Total Station
General tab

Total Station
Advanced tab

Controller
TPS

Receiver
TPS
Topcon Topcon Link Reference Manual
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Figure 2-7. Select COM Port

4. Click Apply, then OK to set the information and close 
the Properties dialog box.

Select Files to Import
5. Click Next on the Import from Device dialog box.

6. In the left panel, select the desired file(s) (hold the 
Shift key to select multiple files) (Figure 2-8).

Figure 2-8. Select Files to Import

7. In the right panel, navigate to and select, or create, the 
folder in which to save the files.
P/N 7010-0522 www.topconpositioning.com
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8. Click Next. The Status bar displays the import progress 
(Figure 2-9).

Figure 2-9. Import Progress

If the receiver is switched off, or a COM or USB Port was 
selected incorrectly, the following dialog box displays 
(Figure 2-10).

Figure 2-10. Cannot Connect Error Message

Click OK, and check the receiver’s connections. Then 
repeat the process.

Importing TPS Controller Files
To import data from a TPS Controller to Topcon Link, first 
install Microsoft® ActiveSync® onto the computer. 
ActiveSync establishes a connection between the computer and 
a mobile device, such as a TPS Controller. The mobile device 
must have the Windows CE operating system. ActiveSync is 
available for free from the Microsoft website (http://
www.microsoft.com).

To establish the connection between the computer and TPS 
Controller, do the following:

1. Using an RS-232 interface cable, connect the TPS 
Controller to the serial interface port on the computer.

2. Switch on the TPS Controller and computer.

3. Start Microsoft ActiveSync.

4. Click Next on the Get Connected dialog box 
(Figure 2-11 on page 2-7).
Topcon Topcon Link Reference Manual
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Figure 2-11. ActiveSync – Get Connected

The computer establishes a connection with the TPS Controller. 
If the TPS Controller is switched on, and the correct COM Port 
selected, the following dialog box displays (Figure 2-12).

Figure 2-12. PC and Controller Connected

The system tray also displays a green circle, indicating a 
successful TPS controller-to-computer connection 
(Figure 2-13).

Figure 2-13. Connection Established

Successful
Connection
P/N 7010-0522 www.topconpositioning.com
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NOTICE
TPS Controllers keep *.tsv files as database 
format files; this format cannot be stored on a 
computer. When importing these files from a TPS 
Controller to a computer, Topcon Link converts 
them to an accessible file format (*.tlsv) before 
saving. Topcon Link must be used to convert the 
correct *.tlsv files top the desired format.

CAUTION
To avoid data loss while exporting *.tsv files 
from a TPS Controller to a computer, use only 
Topcon Link. 

Microsoft ActiveSync Settings

If the computer has only one COM Port:

1. Start Microsoft ActiveSync.

2. Click File->Connection Settings (Figure 2-14).

Figure 2-14. File->Connection Settings
Topcon Topcon Link Reference Manual
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3. On the Connection Settings dialog box, click and 
enable the following parameters (Figure 2-15):

• Allow network (Ethernet) and Remote Access Service 
(RAS) server connection with this desktop computer

• Show status icon in Task bar 

Figure 2-15. Connection Settings

In this case, ActiveSync does not request the COM Port 
after disconnecting the TPS Controller from the computer. 
The COM Port connects the computer with a TPS GPS+ 
receiver or Total Station.

If there are two or more COM Ports on the computer:

1. Start Microsoft ActiveSync.

2. Click File->Connection Settings.

3. On the Connection Settings dialog box, set the 
following parameters (Figure 2-16 on page 2-10):

• Click and enable the “Allow serial cable or infrared 
connection to this COM port”
P/N 7010-0522 www.topconpositioning.com
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• Select the desired COM port from the drop-down list 
(usually COM 1)

Figure 2-16. Click Get Connected

In this case Microsoft ActiveSync requests the COM Port 
after disconnecting the controller and computer. The COM 
Port is available only for devices that use the Windows CE 
operating system.

TIP
Use separate COM Ports for computer-to-
controller connections and computer-to-receiver/
Total Station connections.

When reconnecting the computer and TPS Controller, use 
the same serial interface port set in the Connection Settings 
dialog box.
Topcon Topcon Link Reference Manual
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Import TPS Controller Files

1. Click the Import from Device icon. On the Import 
from Device dialog box, select the TPS Controller icon 
and press Next (Figure 2-17).

Figure 2-17. Select TPS Controller

2. On the next Import from Device dialog box, select the 
desired *.tsv file in the left panel (Figure 2-18).

Figure 2-18. Select Files

3. In the right panel, select a folder in which to save the 
file. Create a new folder if needed.

4. Press Next. The Status bar displays the import progress 
(Figure 2-19).

Figure 2-19. Import Progress
P/N 7010-0522 www.topconpositioning.com
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Importing Total Station Files
The following sections describe importing data files from a 
Topcon Conventional or Robotic Total Station to a computer.

1. On the Import from Device dialog box, right-click a 
Conventional/Robotic Total Station icon and click 
Properties on the pop-up menu (Figure 2-20).

Figure 2-20. Right-Click Total Station

2. On the Properties dialog box, click the General tab and set 
the following information (Figure 2-21), then click Apply:

• Select the model of a total station.

• Enter any applicable notes.

• Select the computer serial port the Total Station is 
connected to.

Figure 2-21. Properties – General Tab
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3. Click Advanced and set the Baud Rate, Data Bits, Parity, 
Stop Bits, and Protocol (Figure 2-22). Click OK to apply 
the information and close the dialog box. 

Figure 2-22. Properties – Advanced Tab

4. Follow all the steps given in the Instruction panel on the 
Import from Device dialog box (Figure 2-23) to prepare 
the Total Station for importing files. Select the file to 
import.

Figure 2-23. Total Station Instructions – Preparing for Import

5. Click Next on the Import from Device dialog box. The 
Status bar displays the import progress (Figure 2-24).

Figure 2-24. Import Progress
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If the data file was successfully imported from the total 
station to the computer the following window displays 
(Figure 2-25).

Figure 2-25. Successful Import

6. Click OK.

7. On the Save file imported from Total Station to dialog box, 
define a folder for the file, select the file type and enter a 
file name (Figure 2-26).

Figure 2-26. Save Imported File

8. Click Save.

If the total station is switched off, not ready for data transfer, or 
the communication parameters are incorrect, the following 
window displays (Figure 2-27).

Figure 2-27. Cannot Connect Error Message

Check the device’s connections, and repeat the process.
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Exporting Files
The following sections describe exporting from a computer:

• an Option Authorization File (OAF) to a TPS GPS+ Receiver;

• Coordinate data files to a Conventional/Robotic Total Station;

• Any type of file to a TPS Controller.

1. To import files, do one of the following:

• Click File->Export to Device (Figure 2-1). 

Figure 2-28. File->Export to Device

• Press F8.

• Click the Export button on the Toolbar (Figure 2-2).

Figure 2-29. Export To Device – Toolbar Button

This dialog box consists of two panels (Figure 2-30 on 
page 2-16):

• The upper panel displays icons of the four types of devices 
that provide data files. Initially, the previously chosen 
device is selected.

• The lower panel displays specific instructions for getting a 
device ready to export files.
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Figure 2-30. Export To Device

Exporting Files to Total Stations
The following procedure describes exporting coordinate files 
from a computer to any listed model total station.

1. On the Import from Device dialog box, right-click a 
Conventional/Robotic Total Station icon and click 
Properties on the pop-up menu (Figure 2-31).

Figure 2-31. Right-click a Total Station
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2. On the Properties dialog box, click the General tab and set 
the following information (Figure 2-32), then click Apply:

• Select the model of a total station.

• Enter any applicable notes.

• Select the computer serial port the Total Station is 
connected to.

Figure 2-32. Properties – General Tab

3. Click Advanced and set the Baud Rate, Data Bits, Parity, 
Stop Bits, and Protocol (Figure 2-33). Click OK to apply 
the information and close the dialog box. 

Figure 2-33. Properties – Advanced Tab
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4. Follow all the steps given in the Instruction panel on the 
Export to Device dialog box (Figure 2-34) to prepare the 
Total Station for exporting files.

Figure 2-34. Total Station Instructions – Preparing for Export

5. Press Next on the Export to Device dialog box.

6. On the Export to Total Station from dialog box, navigate to 
and select the desired file (Figure 2-35).

Figure 2-35. Export To TotalStation From...

7. Click Open. Check the Total Station for the exported file 
(refer to the Total Station’s documentation).
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Exporting an OAF to TPS Receivers
Topcon Positioning System issues an Option Authorization File 
(OAF) to enable the specific options purchased for a TPS 
receiver. An OAF allows each receiver to be customized based 
on particular needs. Use the following steps to load an OAF 
from a computer to a TPS receiver.

1. On the Export to Device dialog box, right-click the TPS 
Receiver icon and click Properties on the pop-up menu 
(Figure 2-36).

Figure 2-36. Export to Device – Receiver

2. Select the computer port (serial or USB) the receiver is 
connected to (Figure 2-37).

Figure 2-37. TPS Receiver Properties

3. Press Next on the Export to Device dialog box.
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4. On the Select file to upload dialog box, navigate to and 
select the OAF file for this TPS receiver (Figure 2-38).

Figure 2-38. Select File To Upload

5. Click Open. The Status bar displays the uploading 
progress (Figure 2-39).

Figure 2-39. Upload Progress

If the OAF loads successfully from the computer to the TPS 
receiver, Topcon Link displays a confirmation message 
(Figure 2-40).

Figure 2-40. File Uploaded Successfully
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Exporting Files to TPS Controllers
To export data from Topcon Link to a TPS Controller, first 
install and start Microsoft® ActiveSync™ on the computer (see 
“Importing TPS Controller Files” on page 2-6). A green icon 
on the system tray indicates a successful connection between 
the computer and TPS Controller.

When exporting files, Topcon Link exports coordinate files and 
TopSURV database files from a computer to a TPS Controller.

• When exporting TopSURV database files, Topcon Link 
converts *.tlsv job format to the *.tsv job format.

• When exporting coordinates files, Topcon Link leaves the 
files in the current format.

CAUTION
To avoid data loss, use only Topcon Link 
when exporting *.tlsv files from a computer to 
a TPS Controller.

1. On the Export to Device dialog box, select a TPS 
Controller and click Next (Figure 2-41).

Figure 2-41. Export to Device – Controller
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2. In the left panel, select the desired coordinate file for export 
(Figure 2-42).

Figure 2-42. Select File for Export and Folder for File

3. In the right panel, select the TPS Controller folder in which 
to export the file.

4. Press Next. The Status bar displays the export progress 
(Figure 2-43).

Figure 2-43. Export Progress
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Topcon Link™ converts files from:

• Coordinate file formats:

–Topcon Total Station (GTS-7, FC-5, GTS-210/310-10, 
GTS-210/310-12)

–Char-delimited (Name,Lat,Lon,H,Code; 
Name,N,E,Z,Code; Name,E,N,Z,Code; Custom)

–ASCII / TSV

–TDS (CR5)

• Measurement file formats from Topcon Total Station raw data 
formats (GTS-6, GTS-7, GTS-7+, FC-5, GTS-210/310)

• TopSURV file format (TopSURV)

• Topcon XML file format (XML)
• GPS+ raw measurements file formats

–RINEX

–TPD (Topcon Positioning Data)

–TPS / JPS

• TDS Raw Data File

• Geoid file

• Feature file
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Topcon Link converts files to:

• Any coordinate file to:

–Any other coordinate file

–Topcon XML

–TopSURV

–DXF

–GIS (Shape, LandXML, DXF)

• Any measurement file to:

–Any other measurement file

–Any coordinate file

–GIS (Shape, LandXML, DXF)

–Topcon XML

–TopSURV

• TopSURV file to:

–Any coordinate file

–Any measurement file

–GIS (Shape, LandXML, DXF)

–Topcon XML

–GPS Vector file

• Topcon XML file to:

–Any coordinate file

–Any measurement file

–GIS (Shape, LandXML, DXF)

–TopSURV

• RINEX file to TPD

• GPS+ TPS / JPS files and TPD files to RINEX
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• TSD Raw Data File containing measurement file form a Total 
Station:

–Any coordinate file

–Any measurement file

–GIS (Shape, LandXML, DXF)

–Topcon XML

–TopSURV

• TDS Raw Data File containing RTK data:

–Any coordinate file

–Any measurement file

–GIS (Shape, LandXML, DXF)

–Topcon XML

–GPS Vector file

• Geoid file to Topcon Geoid file

• Feature File to TopSURV file

1. To convert a file from one format to another, do one of the 
following:

• Click File->Convert to File (Figure 3-1).

Figure 3-1. File->Convert File.

• Press F5.
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• Click Convert File on the Toolbar (Figure 3-2).

Figure 3-2. Convert File – Toolbar Button

The Convert File dialog box displays (Figure 3-3).

Figure 3-3. Convert File Dialog Box

• The left panel displays parameters and values used in 
the field operations of the file.

• The right panel displays parameters and values 
necessary after the conversion.

2. In the left panel, select file type (Figure 3-4).

Figure 3-4. File Format List
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3. Click Browse (“...”) and select the file for conversion in the 
Open for convert dialog box (Figure 3-5).

Figure 3-5. Open for Convert

4. Click Open. The path of the source file displays in the Source 
field (Figure 3-6).

Figure 3-6. Convert File – Source

5. In the right panel, enter the destination file name and type.

6. Click Browse (“...”) and select or create a folder in the Select a 
file dialog box, then select the destination file type and enter the 
destination file name. Click Select (Figure 3-7).

Figure 3-7. Select A File
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7. Click Advanced Options to display further conversion 
parameters. Enter the desired information (Figure 3-8).

Figure 3-8. Convert File – Advanced Options

8. Click Convert in the Convert File dialog box to start the file 
conversion (Figure 3-8).

The following operations depend on the format type of the source 
and destination files. See the following sections for specific 
conversion parameters and information.

Converting Coordinate Files
If converting a coordinate type file, specify the following 
parameters in the left/right panels:

• The file format (Figure 3-9).

Figure 3-9. Coordinate File Formats
Topcon Topcon Link Reference Manual



Converting Coordinate Files

3-7
• In the left panel, enable Orthometric Height when the file uses 
orthometric heights (Figure 3-10).

Figure 3-10. Orthometric Height Checkbox

• In the left panel, enable Control to fix the coordinates of points 
when converting the file to a *.tlsv file (Figure 3-11).

Figure 3-11. Control Checkbox

• In the right panel, enable Orthometric Height to calculate 
orthometric heights for the converted points (Figure 3-12).

Figure 3-12. Orthometric Height

• In the right panel, set the Geoid model:

1. Click Geoids List (Figure 3-13).

Figure 3-13. Geoids list button

2. On the Geoids List dialog box, click Add
(Figure 3-14).

Figure 3-14. Geoids List Dialog Box
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3. Select the desired *.bin file in Open dialog box and 
click Open (Figure 3-15).

Figure 3-15. Open window

4. Click Close (Figure 3-16).

Figure 3-16. Geoids List

• In the right panel, select a geoid model (Figure 3-17).

Figure 3-17. Select Geoid Model
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ASCII/TSV and Custom Text Format 
Parameters
For ASCII/TSV or Custom Text formats, specify:

• A projection name for the coordinate type (Figure 3-18).

Figure 3-18. Projection List

• Or a Datum for Lat,Lon,H coordinate type (Figure 3-19).

Figure 3-19. Datum List

• Linear units (Figure 3-20).

Figure 3-20. Linear Units List
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Name,Lat,Lon,H,Code Format Parameters
For Name,Lat,Lon,H,Code formats, specify the following 
parameters:

• Datum (Figure 3-21)

Figure 3-21. Datum List

• Linear units (Figure 3-22)

Figure 3-22. Linear Unit List

Other Coordinate File Types Format 
Parameters
For GTS-7 Points, FC-5, GTS-210/310-10, GTS-210/310-12, 
Name,E,N,Z,Code or Name,N,E,Z,Code formats, specify the 
following parameters:

• Projection (Figure 3-23).

Figure 3-23. Projection List
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• Linear units (Figure 3-24)

Figure 3-24. Linear Unit List

• When converting from (left panel) GTS-7 Points, FC-5, 
GTS-210/310-10 and GTS-210/310-12 file formats, enter 
the Grid and Ground transformation parameters using the 
following procedure:

1. Click and enable the Grid->Ground Parameters check 
box (Figure 3-25).

Figure 3-25. For Grid Coordinate Type, Enable Grid->Ground Parameters

2. Click the Grid to Ground Parameters button 
(Figure 3-26).

Figure 3-26. Grid to Ground Parameters Button

3. Enter the applicable transformation parameters 
(Figure 3-27).

Figure 3-27. Grid to Ground Parameters

4. Click OK.

• When converting to (right panel) GTS-7 Points, FC-5 
Points, GTS-210/310-10 Points and GTS-210/310-12 
Points file formats, a coordinate file is created that contains 
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Ground coordinates. To convert Ground coordinates to Grid 
coordinates, see the above procedure.

Converting TopSURV Files
If converting a TopSURV file, select the correct file format 
(Figure 3-28) and click Convert.

Figure 3-28. File Format List

Converting Total Station Raw Data 
Files
If converting a Total Station (TS) measurement file, specify the 
following parameters in the left/right panels.

In the left panel,

• the File format (Figure 3-29).

Figure 3-29. File Format List
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• the Projection type (Figure 3-30).

Figure 3-30. Projection List

• the relation between the Grid and Ground coordinates:

1. Click and enable the Grid->Ground Parameters check 
box (Figure 3-31).

Figure 3-31. For Grid Coordinate Type, Enable Grid->Ground Parameters

2. Click the Grid to Ground coordinates button 
(Figure 3-32).

Figure 3-32. Grid to Ground Coordinates Button

3. On the Grid->Ground Parameters dialog box, enter 
the transformation parameters (Figure 3-33).

Figure 3-33. Grid->Ground Parameters Dialog Box
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• the order of the coordinates (Figure 3-34).

Figure 3-34. Coordinate Order List

In the right panel,

• the File format (Figure 3-35).

Figure 3-35. File Format List

• the Projection type (Figure 3-36).

Figure 3-36. Projection List

• the relation between the Grid and Ground coordinates:

1. Click and enable the Grid->Ground Parameters check 
box (Figure 3-31).

Figure 3-37. For Grid Coordinate Type, Enable Grid->Ground Parameters
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2. Click the Grid to Ground coordinates button 
(Figure 3-38).

Figure 3-38. Grid to Ground Coordinates Button

3. On the Grid->Ground Parameters dialog box, enter 
the transformation parameters (Figure 3-39).

Figure 3-39. Grid->Ground Parameters Dialog Box

• the Linear units (Figure 3-40).

Figure 3-40. Linear Units List

• the Angular units (Figure 3-41).

Figure 3-41. Angular Units List

• the Coordinate order (Figure 3-42).

Figure 3-42. Coordinate Order List

Converting Topcon XML Files
If converting a Topcon XML file, set the following parameters in 
the left panel:
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• Select the File format (Figure 3-43).

Figure 3-43. File Format List

• Select the Coordinate type (Figure 3-44).

Figure 3-44. Coordinate Type List

If Ground or Grid coordinate type is selected, set the 
Projection, Linear unit, and Angular unit (Figure 3-45).

Figure 3-45. Projection, Linear Unit, Angular Unit Lists
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If the Lat,Lon,H coordinate type is selected, set the Datum, 
Linear unit, and Angular unit (Figure 3-46).

Figure 3-46. Datum, Linear Unit, and Angular Unit Lists

• If Ground coordinates selected, enter the relation between the 
Grid and Ground coordinates:

1. Click and enable the Grid->Ground Parameters check 
box (Figure 3-47).

Figure 3-47. For Grid Coordinate Type, Enable Grid->Ground Parameters

2. Click the Grid to Ground coordinates button 
(Figure 3-48).

Figure 3-48. Grid to Ground Coordinates Button
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3. On the Grid->Ground Parameters dialog box, enter 
the transformation parameters (Figure 3-49).

Figure 3-49. Grid->Ground Parameters Dialog Box

Converting LandXML Files
If converting a LandXML file, set the following parameters in the 
left panel:

• Select the File format (Figure 3-50).

Figure 3-50. File Format List

• Select the Coordinate type (Figure 3-51).

Figure 3-51. Coordinate Type List
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If Ground or Grid coordinate type is selected, set the 
Projection and Linear unit (Figure 3-52).

Figure 3-52. Projection, Linear Unit, Angular Unit Lists

If the Lat,Lon,H coordinate type is selected, set the Datum 
and Linear unit Angular unit (Figure 3-53).

Figure 3-53. Datum, Linear Unit, and Angular Unit Lists

• If Ground coordinates selected (Figure 3-54 on page 3-20), 
enter the relation between the Grid and Ground coordinates:

1. Click and enable the Grid->Ground Parameters check 
box (Figure 3-54 on page 3-20).
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Figure 3-54. For Grid Coordinate Type, Enable Grid->Ground Parameters

2. Click the Grid to Ground coordinates button 
(Figure 3-55).

Figure 3-55. Grid to Ground Coordinates Button

3. On the Grid->Ground Parameters dialog box, enter 
the transformation parameters (Figure 3-56).

Figure 3-56. Grid->Ground Parameters Dialog Box

Converting GPS+ Raw Data Files
If converting a GPS+ Raw Data file (TPS, JNS, RINEX, TPD), 
select the correct file format in the From panel (Figure 3-57).

Figure 3-57. File Format List
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Converting to GIS Files
If converting to a GIS file, specify the following parameters in the 
right panel:

• Select the file format (Figure 3-58).

Figure 3-58. File Format List

• Select the coordinate type (Figure 3-59).

Figure 3-59. Coordinate Type List

If Ground or Grid coordinate type is selected, set the 
Projection and Linear units (Figure 3-60).

Figure 3-60. Projection and Linear Unit Lists
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If the Lat,Lon,H coordinate type is selected, set the Datum 
and Linear units (Figure 3-61).

Figure 3-61. Datum and Linear Unit Lists

• For Ground coordinates, set the relation between the Ground 
coordinates and Grid coordinates. See steps 1 through 3 on 
page 3-19 for this procedure.

• Enable Orthometric Height to calculate orthometric heights for 
the converted points (Figure 3-62).

Figure 3-62. Orhtometric Height

• Set the Geoid model:

1. Click Geoids List (Figure 3-63).

Figure 3-63. Geoids list button
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2. On the Geoids List dialog box, click Add
(Figure 3-64).

Figure 3-64. Geoids List Dialog Box

3. Select the desired *.bin file in Open dialog box and 
click Open (Figure 3-65).

Figure 3-65. Open Window

4. Click Close (Figure 3-66).

Figure 3-66. Geoids List

• Select a geoid model (Figure 3-67).

Figure 3-67. Select Geoid Model
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Converting to TPD GPS+ Raw Data 
Files
If converting to a TPD GPS+ Raw Data file, select the correct file 
format in the To panel (Figure 3-68).

Figure 3-68. File Format List

Converting to RINEX GPS+ Raw Data 
Files
If converting to a RINEX GPS+ Raw Data file, set the following 
parameters in the To panel:

• Select the File format (Figure 3-69).

Figure 3-69. File Format List

• Click GLONASS to include or exclude raw GLONASS data 
measurements/ephemeris data (Figure 3-70 on page 3-25).
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• Click L1 and/or L2 to include or exclude L1 or L2 raw data 
measurements (Figure 3-70). If both fields are disabled 
(unchecked), Topcon Link creates only a navigational file 
(*.0?o).

Figure 3-70. RINEX Advanced Options – Enabled

Converting TDS Raw Data Files
If converting a TDS measurement file, specify the following 
parameters in the left panel:

• the File format (Figure 3-71).

Figure 3-71. TDS Raw Data File Formats

• the Projection type (Figure 3-72).

Figure 3-72. Projection List
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• the Linear units (Figure 3-73).

Figure 3-73. Linear Units List

• the Angular units (Figure 3-74).

Figure 3-74. Angular Units List

Converting Geoid Files
If converting a Geoid file, select the correct file in the From panel 
(Figure 3-75).

Figure 3-75. Global Geoid Format
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Converting Topcon Geoid Files
Geoid files can be converted to the Topcon Geoid file format for use 
in Topcon Tools and TopSURV.

If converting to a Topcon Geoid file, set the following parameters in 
the To panel:

• Select the File format (Figure 3-76).

Figure 3-76. Geoid File Format

• Specify positions for the points limiting the use of this geoid 
model (Figure 3-77).

Figure 3-77. Point Limits

NOTE: Enter latitude and longitudes and the format shown in 
Figure 3-78.

Figure 3-78. Latitude and Longitude Format

TIP
Latitudes are positive for the Northern 
Hemisphere. Longitudes are positive for the 
Eastern Hemisphere.
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Converting Feature Files
In converting a Feature file, select the correct file in the From panel 
(Figure 3-79).

Figure 3-79. Feature File Format

Converting to GPS Vector File
If converting to a GPS Vector file, in the To panel, select the file 
format (Figure 3-80).

Figure 3-80. GPS Vector File Format

See Appendix C for more details.
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This chapter discusses opening, viewing, and editing files in 
Topcon Link™.

Opening Files
Topcon Link can open the following formats and types of files:

• Coordinate file formats:

–Topcon Total Station (GTS-7, FC-5, GTS-210/310-10, 
GTS-210/310-12)

–Char-delimited (Name,Lat,Lon,Ht,Code; Name,N,E,Z,Code; 
Name,E,N,Z,Code; Custom)

–TSV ASCII

–TDS (CR5)

• Measurement file formats from Topcon Total Stations 
(GTS-6, GTS-7, GTS-7+, FC-5, GTS-210/310)

• TopSURV file format (TopSURV files).

• Feature file

1. To open a file, do one of the following:

• Click File->Open File (Figure 4-1).

Figure 4-1. File->Open File...
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• Press Ctrl+O.

• Click Open on the Toolbar (Figure 4-2).

Figure 4-2. Open – Toolbar Button

The Open dialog box displays (Figure 4-3).

Figure 4-3. Open Dialog Box

2. To select the file format, use the Format name drop-down list to 
do one of the following:

• Select the file format if known beforehand (Figure 4-4).

Figure 4-4. File Format
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• Select the file type if the file type is known and the file 
format is unknown (Figure 4-5).

Figure 4-5. File Type

• Select All Files if the file format and type are unknown 
(Figure 4-6). In this case Topcon Link software 
automatically detects the file type and format.

Figure 4-6. All Files

3. Click Open. The file opens in Topcon Link.

Selecting an incompatible file name and file format displays an 
error message (Figure 4-7).

Figure 4-7. Unknown File Format Error Message

Select the correct file name or format and repeat the process.
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Creating User-defined File Formats
To open a file of arbitrary coordinates format, create and save a 
user-defined format using the Open dialog box. 

1. In the Open dialog box, select Custom Text Format in the 
Format name drop-down list and type a name for the file in 
the File name field (Figure 4-8). Click Open.

Figure 4-8. Custom Text Format

2. In the Custom format properties dialog box, enter the file’s 
parameters (Figure 4-9 on page 4-5).

• Delimiters – the separating character type; either 
Comma, Space, Tab, or Semicolon.

• Coordinate system – Grid, Ground, or BLH.

• Coordinates order, codes, and comments. Select the 
desired entry (names, coordinates, codes, comments), 
then:

–Use the right arrow button to move entries from the 
left field to the right field. The order of names in the 
right field must correspond the order of names in the 
opened file.

–Use the left arrow button to move entries out of the 
right panel and back to the left panel.

–Use the Move Up and Move Down buttons to move 
names in the right panel up and down.

• The format name and the format’s file extension.
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Figure 4-9. Custom Format Properties

3. Click OK. Topcon Link will do the following:

• Store the user-defined format description in the 
Formats folder.

• Store the format name in the list of the coordinate file 
formats (Figure 4-10).

Figure 4-10. Format Name Stored in File Format List

• Attempt to open the selected file.

NOTICE
Topcon Link applies the default file name, 
UnName*.*, if no file name accompanies the new 
coordinate file format. In this case, Topcon Link 
deletes the new file format when closed.
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Viewing Files
After opening a file, or transferring a file from an external device, a 
data table displays in the Topcon Link work area.

Coordinate File Data Table
Coordinate Files display information on one tab in the data 
table (Figure 4-11).

Figure 4-11. Coordinate File

The Points tab (Figure 4-11) has the following columns:

• Name – the name of the point

• Northing – the measured northing coordinate for the point 
and coordinate type

• Easting – the measured easting coordinate for the point and 
coordinate type

• Elevation – the elevation of the point

• Note – any notes associated with the point

• Code – any codes associated with the point
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Table 4-1 lists the symbols Topcon Link uses to represent 
different information on the data table.

Total Station Raw Data File Data Table
Total Station (TS) raw data files display information on two 
tabs in the data table (Figure 4-12).

Figure 4-12. Total Station Raw Data File

The Points tab (Figure 4-12) has the following columns for 
measured (not calculated) points:

• Name – the name of the point

• Northing – the measured northing coordinate for the point 
and the coordinate type

Table 4-1. Coordinate File Symbols

Location Symbols Description

Coordinate file symbols

Point Tab
Unknown point

Fixed coordinates point
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• Easting – the measured easting coordinate for the point and 
the coordinate type

• Elevation – the elevation of the point

• Note – any notes associated with the point

• Code – any codes associated with the point

The left panel of the TS Obs tab (Figure 4-13 on page 4-8) has 
the following columns for points with known coordinates:

• # – the number of the point

• Point Name – the name of the point

• Instrument Height – the height of the instrument in the 
selected units (ft, m)

Figure 4-13. TS Obs Tab – Left Panel

The right panel of the TS Obs tab (Figure 4-14) has the 
following columns for points with unknown coordinates 
measured from the point in the left panel:

• # – point number

• Point From – the beginning of the vector

• Point To – the end of the vector

• Reflector Height – the height of the reflector

• Azimuth, Horizontal Circle, Zenith Angle, Slope Distance 
– angular and linear measurements in the selected unit (ft, 
m)

• Code – any code associated with the point
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• Type – the type of point (BS, SS, FS, or BKB)

Figure 4-14. TS Obs Tab – Right Panel

Table 4-2 lists the symbols Topcon Link uses to represent 
different information on the data table.

Table 4-2. Total Station Raw Data File Symbols

Location Symbols Description

TS raw data measurements file symbols

Points Tab
TS station

TS point

TS Obs Tab, Left 
Panel

TS station

TS Obs Tab, 
Right Panel

ForeSight measurement

SideShot measurement

BackSight

BackSightBearing point measurement

TS Resection Observation
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TopSURV File Data Table
TopSURV raw data files display information on four tabs in the 
data table (Figure 4-15).

Figure 4-15. TopSURV Raw Data File

The Points tab (Figure 4-15) has the following columns:

• Name – the name of the point

• Northing – the measured northing coordinate for the point 
and the coordinate type

• Easting – the measured easting coordinate for the point and 
the coordinate type

• Elevation – the elevation of the point

• Note – any notes associated with the point

• Code – any codes associated with the point

The GPS Occupations tab (Figure 4-16 on page 4-11) has the 
following columns for individually measured points:

• Point Name – the name of the point

• Antenna Type – the type of antenna used at the point

• Antenna Height – the height of the antenna in the selected 
unit (ft, m)
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• Antenna Height Method – the method used to measure the 
antenna height (vertical or slant)

• Start Time – the starting time of the measurement

• Duration – the length of time of the measurement

Figure 4-16. GPS Occupations Tab

The left panel of the TS Obs tab (Figure 4-17 on page 4-12) has 
the following columns for points with known coordinates:

• # – the number of the point

• Point Name – the name of the point

• Instrument Height – the height of the instrument in the 
selected units (ft, m)

The right panel of the TS Obs tab (Figure 4-17 on page 4-12) 
has the following columns for points with unknown coordinates 
measured from the point in the left panel:

• # – point number

• Point From – the beginning of the vector

• Point To – the end of the vector

• Reflector Height – the height of the reflector

• Azimuth, Horizontal Circle, Zenith Angle, Slope Distance 
– angular and linear measurements in the selected unit (ft, 
m)

• Code – any code associated with the point
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• Type – the type of point (BS, SS, FS, or BKB)

Figure 4-17. TS Obs Tab

The GPS Obs tab (Figure 4-18 on page 4-13) has the following 
columns for baseline measurements from the Base station to the 
Rover station’s point:

• Point From – the starting point of the baseline measurement

• Point To – the ending point of the baseline measurement

• Start Time – the date and time of the start of the 
measurement

• Duration – the length of time of the measurement

• Notes – any notes for the baseline measurement

• Horizontal Precisions, Vertical Precisions – displays 
horizontal and vertical precisions of the measurement

• dn, de, du – displays increments of the measurement

• Method – displays the measurement method (RTK Topo, 
RTK Auto)

• Solution type – displays the type of solution used for the 
measurement:

–Failed: impossible to process measurement

–Code Diff: code difference measurement

–Phase Diff Float: float phase difference measurement

–Phase Diff Fixed: fixed phase difference measurement
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Figure 4-18. GPS Obs Tab

The left panel of the Codes tab (Figure 4-19) has a table of 
available *.tslv file codes.

The right panel of the Codes tab (Figure 4-19) has the 
following columns:

• Name – a unique name for the code

• Default value – a numeric default value for the code

• Type – the type of code (numeric, text, or list)

Figure 4-19. Codes Tab
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Table 4-3 lists the symbols Topcon Link uses to represent 
different information on the data table.

Table 4-3. TopSURV File Symbols

Location Symbols Description

TopSURV TS file symbols

Points Tab

TS station

TS point

TS BackSight point

Point coordinates input manually

Point coordinates calculated by means of 
COGO

Design point

Stakeout point

Fixed coordinates point

TS Obs Tab, Left 
Panel

TS station

TS Obs Tab, 
Right Panel

ForeSight measurement

SideShot measurement

BackSight measurement

BackSightBearing point measurement

TS Resection Observation

TS MLM Observation
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TopSURV RTK file symbols

Points Tab

Base station

Located static point

Located kinematic point 

Point coordinates input manually

Point coordinates calculated by means of 
COGO

Design point

Stakeout point

Fixed coordinates point

GPS Occupation 
Tab

Base station occupation

Static occupation

Kinematic occupation 

GPS Obs Tab, 
Baseline from base station to static point

Baseline from base station to kinematic point

Table 4-3. TopSURV File Symbols

Location Symbols Description
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Viewing File Properties
To view an open file’s properties, click File->File properties 
(Figure 4-20).

Figure 4-20. File->File Properties

• Coordinate files – displays the path to the opened file and 
the file format (Figure 4-21).

Figure 4-21. Properties for Coordinate File

• TopSURV files – displays the file name, path to the opened 
file, file format, job name, and surveyor’s name 
(Figure 4-22).

Figure 4-22. Properties for TopSURV File
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• Total Station raw data files

–displays name and format data in the General tab 
(Figure 4-21); 

–displays date, instrument, job, survey’s name, and 
note data in the Session tab (Figure 4-23).

Figure 4-23. Properties for TS Raw Data File – Session

Editing Files
Once a file has been imported and/or converted, editing the file 
provides hands-on data usage, administration and handling. Saving 
the file prevents data loss, as well as providing a means for sharing 
and exporting files.

Saving Files
When saving as edited file (*.*) for the first time, Topcon Link 
makes a copy of the initial file (*.*.initial) in the current folder 
before saving. This file is left unchanged. All changes will be 
saved in the *.* file.

Save Changes to Current File and Format

To save changes, do one of the following:

• Click File->Save File.

• Press Ctrl+S.

• Click Save on the Toolbar.
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• Close the current window and click Yes in the Save 
Changes? dialog box.

Save Changes to a Different Format

NOTICE
Topcon Link cannot save edited information if the 
file currently lacks those fields. If Note or Code 
information changed for GTS-210/310-10, GTS-
210/310-12, FC-5 format files or user-defined 
format files without Note or Code columns, 
Topcon Link will display the following dialog box 
(Figure 4-24). Save the file as a different format.

Figure 4-24. Save to Another Format?

• Click No or Cancel to continue without saving.

• Click Yes to continue saving the file.

1. To save the file to a different format, click Yes.

2. On the Save as dialog box, do one of the following:

–Select a user-defined format in the Format File field 
that includes Note and Code columns 
(Figure 4-25).

Figure 4-25. Format Name

–Define a new format that includes Note and Code 
columns. Select Custom Text Format in the Format 
File window and click Open. Then define new file 
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format that includes Note and Code columns. See 
“Creating User-defined File Formats” on page 4-4 for 
more information. 

3. Enter the name and location of the new file.

4. Click Save.

Save Changes to a Different File

To save a file with another name:

1. Click File->Save As.

2. Select or create a destination folder and enter a new 
name in the Save As dialog box (Figure 4-26).

Figure 4-26. Save As Dialog Box

3. Click Save.
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Editing Coordinate Files
In coordinate files (Figure 4-27), the following information can 
be edited:

• Point name

• Point coordinate

• Note

• Code

• Coordinate point order

Figure 4-27. Coordinate File

To edit coordinate file information, right-click one of the point 
rows to display the coordinate file pop-up menu (Figure 4-28).

Figure 4-28. Coordinate File Pop-up Menu

• Cut – cuts the information

• Copy – copies the information

• Delete – deletes the information

• Properties – displays the properties dialog box.
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Edit Name and Note Properties

To edit point Name and Note properties in a coordinate file:

1. Right-click a point and click Properties on the pop-up 
menu.

2. On the Properties dialog box, click the General tab 
(Figure 4-29).

Figure 4-29. Coordinate Properties – General Tab

3. Edit the Name and Note fields as needed.

4. Click OK to set the changes and close the dialog box. 
Click Apply to set the changes and continue editing the 
point.
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Edit Coordinate Properties

To edit point Coordinate properties in a coordinate file:

1. Right-click a point and click Properties on the pop-up 
menu.

2. On the Properties dialog box, click the Coordinates tab 
(Figure 4-30).

Figure 4-30. Coordinate Properties – Coordinates Tab

3. Edit the Northing, Easting, and Elevation fields as 
needed.

4. Click OK to set the changes and close the dialog box. 
Click Apply to set the changes and continue editing the 
point.

5. To change the order of coordinate points, click 
File->Job Configuration. 

6. On the Job Configuration dialog box, click Display 
and then the Points tab (Figure 4-31).

Figure 4-31. Job Configuration – Points Tab

7. Change the coordinate order as needed. Click OK.
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Edit CAD Properties

To edit CAD properties of a point in a coordinate file,

1. Right-click a point and click Properties on the pop-up 
menu.

2. On the Properties dialog box, click the CAD tab 
(Figure 4-30).

Figure 4-32. Coordinate Properties – CAD Tab

3. Select or edit the Codes as needed.

4. Click OK to set the changes and close the dialog box. 
Click Apply to set the changes and continue editing the 
point.

Editing Total Station Raw Data Files
In Total Station (TS) raw data files (Figure 4-33 on page 4-24), 
the following information can be edited:

• Point name and point number

• Instrument height

• Point to and point notes

• Reflector height and azimuth

• Offsets

• CAD information

• String properties

• Observation display
P/N 7010-0522 www.topconpositioning.com



Maintaining Files

4-24
Figure 4-33. Total Station Raw Data File

To edit left panel TS point file information, right-click a point 
row to display the left panel pop-up menu (Figure 4-34).

Figure 4-34. TS Point File – Left Panel Pop-up Menu

To edit right panel TS point file information, right-click a point 
rows to display the right panel pop-up menu (Figure 4-35).

Figure 4-35. TS Point File – Right Panel Pop-up Menu

• Cut – cuts the information

• Copy – copies the information

• Delete – deletes the information
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• Properties – displays the properties dialog box

• Options – displays the options dialog box

TIP
Click a column’s heading to sort data in 
descending or ascending order.

Edit Name, Instrument Height, and Number 
Properties

To edit name, instrument height, and number properties of 
a point in a TS raw data file,

1. Right-click a point in the left panel and click 
Properties on the pop-up menu.

2. On the Properties dialog box, edit point name, 
instrument height, and point number as needed 
(Figure 4-36).

Figure 4-36. Properties

3. Click OK to set the changes and close the dialog box. 
Click Apply to set the changes and continue editing the 
point.
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Edit Point To and Notes Properties

To edit point to and notes properties of a point in a TS raw 
data file,

1. Right-click a point in the right panel and click 
Properties on the pop-up menu.

2. On the Properties dialog box, click the General tab 
(Figure 4-37).

Figure 4-37. TS Properties – General Tab

3. Edit the Point To, Note, and Code fields as needed.

4. Click OK to set the changes and close the dialog box. 
Click Apply to set the changes and continue editing the 
point.

Edit Reflector Height and Azimuth Properties

To edit reflector height and azimuth properties of a point in 
a TS raw data file:

1. Right-click a point in the right panel and click 
Properties on the pop-up menu.
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2. On the Properties dialog box, click the Observation tab 
(Figure 4-38).

Figure 4-38. TS Properties – Observation Tab

3. Edit the Reflector Height and Azimuth fields as needed.

4. Click OK to set the changes and close the dialog box. 
Click Apply to set the changes and continue editing the 
point.

Edit Offset Properties

To edit offset properties of a point in a TS raw data file:

1. Right-click a point in the right panel and click 
Properties on the pop-up menu.

2. On the Properties dialog box, click the Offset tab 
(Figure 4-39).

Figure 4-39. TS Properties – Offset Tab

3. Edit the Offset fields as needed.
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4. Click OK to set the changes and close the dialog box. 
Click Apply to set the changes and continue editing the 
point.

Edit String Properties

To edit String properties of a point in a TS raw data file 
(only available when the Display String and Control Code 
is enabled; see “Edit Point Code Description” on page 4-
30):

1. Right-click a point in the right panel and click 
Properties on the pop-up menu.

2. On the Properties dialog box, click the String tab 
(Figure 4-40).

Figure 4-40. TS Properties – CAD Tab

3. Edit String and Control Code fields as needed.

4. Click OK to set the changes and close the dialog box. 
Click Apply to set the changes and continue editing the 
point.
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Edit Observation Display Properties

To edit observation display properties of a point in a TS raw 
data file:

1. Right-click a point in the right panel and click Options 
on the pop-up menu.

2. On the Options dialog box and Display tab, select the 
desired display appearance of the Total Station 
Observations data (Figure 4-41).

Figure 4-41. TS Options

3. Click and enable Show offsets to display offsets on the 
data table.

4. Click OK to set the changes and close the dialog box. 
Click Apply to set the changes and continue editing the 
point.
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Edit Point Code Description

To edit the letter/numerical code for point description in a 
TS raw data file:

1. Click File->Job Configuration (Figure 4-42).

Figure 4-42. File->Job Configuration

2. On the Job Configuration dialog box, click Display 
and then the Strings tab (Figure 4-43).

Figure 4-43. Job Configuration – Strings Tab

3. Click the Display String and Control Code option. 
String and Control Code columns will be added to the 
right panel of the TS Obs tab. CAD and String tabs will 
be added to the Properties dialog box.

4. Click OK.
Topcon Topcon Link Reference Manual



Editing Files

4-31
Edit Multiple Points

To edit the Instrument Height, Reflector Height, Comment, 
Point Name, or Measurements for multiple points in either 
panel:

1. Press the Shift key and click several rows 
(Figure 4-44).

Figure 4-44. Select and Edit Multiple Rows of Data

2. Enter the new information to any selected row 
(Figure 4-44).

3. Press Enter to apply the edited data across all rows.

Editing TopSURV Files
In TopSURV files (Figure 4-45 on page 4-32), the following 
information can be edited:

• Point parameters:

–Name and note, point coordinates, and codes

–Coordinate type and coordinate order

• GPS occupations parameters:

–Name

–Antenna type and height, and method of height 
measurement

–Offsets

• TS observation parameters: name; antenna height
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• GPS observation parameters:

–For GPS raw data files: vector notes

–For TS raw data files: instrument name, job ID and 
location, surveyor, and notes; temperature and pressure 
data

Figure 4-45. Sample TopSURV File

To edit TopSURV file information, right-click a point or row to 
display the a pop-up menu (Figure 4-35).

Figure 4-46. TS Point File – Right Panel Pop-up Menu

• Cut – cuts the information

• Copy – copies the information

• Delete – deletes the information

• Properties – displays the properties dialog box

• Options – (only available in some tabs) displays the options 
dialog box
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Edit Point Name and Note Properties

Base station, static, and kinematic point coordinates from 
GPS solutions display in the Points tab. Points computed in 
RTK mode display in the same coordinate system/
projection selected while creating the job in TopSURV.

1. To edit point name, notes and codes, right-click the 
point and click Properties on the pop-up menu.

2. On the Properties dialog box, click the General tab 
(Figure 4-47).

Figure 4-47. Point Properties – General Tab

3. Edit the Name, Note, and Code fields as needed.

4. Click OK to set the changes and close the dialog box. 
Click Apply to set the changes and continue editing the 
point.

Edit Point Coordinates

1. To edit point coordinates, right-click the point and click 
Properties on the pop-up menu.

2. On the Properties dialog box, click the Coordinates tab 
(Figure 4-48 on page 4-34).
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Figure 4-48. Point Properties – Coordinates Tab

3. Edit the Latitude, Longitude, and Ell. Height fields as 
needed.

4. Click OK to set the changes and close the dialog box. 
Click Apply to set the changes and continue editing the 
point.

Add New Point Code

1. To add a new point code, right-click the point and click 
Properties on the pop-up menu.

2. On the Properties dialog box, click the CAD tab 
(Figure 4-47).

Figure 4-49. Point Properties – CAD Tab
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3. Right-click in the Name field and click New Code on 
the pop-up menu (Figure 4-50).

Figure 4-50. Code Pop-up Menu

4. Type the new code Name and press Enter.

5. Click OK to set the changes and close the dialog box. 
Click Apply to set the changes and continue editing the 
point.

Edit GPS Occupation Point Name

1. Click the GPS Occupations tab.

2. To edit point name, right-click the point and click 
Properties on the pop-up menu.

3. On the Properties dialog box, click the General tab 
(Figure 4-51).

Figure 4-51. Point Properties – General Tab

4. Edit the Name field as needed.

5. Click OK to set the changes and close the dialog box. 
Click Apply to set the changes and continue editing the 
point.
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Edit GPS Occupation Antenna Parameters

1. Click the GPS Occupations tab.

2. To edit antenna parameters, right-click the point and 
click Properties on the pop-up menu.

3. On the Properties dialog box, click the Antenna tab 
(Figure 4-51).

Figure 4-52. Point Properties – Antenna Tab

4. Edit the antenna Type, Height, and Method fields as 
needed.

5. Click OK to set the changes and close the dialog box. 
Click Apply to set the changes and continue editing the 
point.

Edit GPS Occupation Offsets

1. Click the GPS Occupations tab.

2. To edit point offsets, right-click the point and click 
Properties on the pop-up menu.

3. On the Properties dialog box, click the Offset tab 
(Figure 4-51).

Figure 4-53. Point Properties – Offset Tab
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4. Edit the Offset fields as needed.

5. Click OK to set the changes and close the dialog box. 
Click Apply to set the changes and continue editing the 
point.

Edit TS Obs Parameters

1. Click the TS Obs tab.

2. To edit TS Obs tab properties, see “Editing Total 
Station Raw Data Files” on page 4-23.

Edit GPS Obs Point Notes

1. Click the GPS Obs tab.

2. To edit the point notes, right-click the point and click 
Properties on the pop-up menu.

3. On the Properties dialog box, click the General tab 
(Figure 4-51).

Figure 4-54. Point Properties – General Tab

4. Edit the Note field as needed.

5. Click OK to set the changes and close the dialog box. 
Click Apply to set the changes and continue editing the 
point.
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View GPS Obs Point Observations

1. Click the GPS Obs tab.

2. To view the point observations, right-click the point 
and click Properties on the pop-up menu.

3. On the Properties dialog box, click the Observation tab 
(Figure 4-51).

Figure 4-55. Point Properties – Observation Tab

4. Click OK to close the dialog box.

Edit GPS Observation Display

1. Click the GPS Obs tab.

2. To edit the GPS observation display, right-click the 
point and click Options on the pop-up menu.

3. On the Options dialog box, the desired coordinate 
baseline (Figure 4-51).

Figure 4-56. Point Properties – General Tab

4. Click OK to set the changes and close the dialog box. 
Click Apply to set the changes and continue editing the 
point.
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Edit TopSURV File Codes

1. Click the Codes tab.

2. To edit the code’s attribute, right-click the code and 
click New Attribute on the pop-up menu, then select 
the desired attribute (Figure 4-57).

Figure 4-57. Select Code Attribute

3. On the Attributes dialog box, enter the applicable 
parameters for the code’s attribute (Figure 4-58, 
Figure 4-59 on page 4-40, and Figure 4-60 on 
page 4-40). Click OK. 

Figure 4-58. Edit Code Numeric Attributes
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Figure 4-59. Edit Code Text Attribute

Figure 4-60. Edit Code Menu Attribute

TIP
Later, double-click the attribute to edit it.

4. To edit the code name, do one of the following:

• Double-click the code’s name, type the new name, and 
press Enter.

• Right-click the code’s name and click Properties on 
the pop-up menu. Edit the code’s name and click OK 
(Figure 4-61).

Figure 4-61. Edit Code Name
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This chapter discusses file functions available in Topcon Link™.

Computing Coordinates
To compute points coordinates using raw data file information:

1. Open a raw data file.

2. Do one of the following:

• Click Process->Compute Coordinates (Figure 5-1).

Figure 5-1. Process->Compute Coordinates

• Click Compute Coordinates on the Toolbar (Figure 5-2).

Figure 5-2. Compute Coordinates– Toolbar Button

NOTICE
If none of the points have known coordinates, 
Topcon Link uses a point with (0, 0, 0) 
coordinates as the beginning point.
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Topcon Link computes points coordinates and adds them to the 
Total Station raw data file window (Figure 5-3).

Figure 5-3. Raw Data File

Traverse Adjustment
The procedure combines points coordinates computation and 
network adjustment.

Network adjustment methods of adjustment may be classified as: 

• Approximate adjustment – includes Interior Angle Balancing, 
Azimuth Balancing, Compass rule (Bowditch Rule), Transit 
Rule, and the Crandall method.

• Rigorous adjustment – includes the method of least squares.

Traditional methods of approximate traverse adjustment have been 
developed to accommodate prevailing conditions in certain 
combinations of angular and linear precisions in the observations.

In this respect, three combinations are still common.:

• Precision in angles or directions exceeds its equivalent in linear 
distance observations.
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• Precision in angles or directions essentially is equal to its 
equivalent in the precision of distances

• Precision in distances exceeds that in angles and directions.

Set Adjustment Type
1. To select a network adjustment type, click Process->

Process Properties.

2. On the Process properties dialog box, select the Compute 
Coordinates tab and choose one of the following the 
Adjustment types (Figure 5-4): 

• None – requires apriori values

• Least Squares – requires apriori values; see “Least 
Squares Method” on page 5-5 for details

• Compass Rule – see “Compass Rule” on page 5-5 for 
details

• Transit – see “Transit Rule” on page 5-6 for details

• Crandall – see “Crandall Method” on page 5-6 for 
details

• Angle Balance – see “Interior Angle Balancing 
Method” on page 5-7 for details

Figure 5-4. Process Properties – Compute Coordinates
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3. Select an azimuth balancing parameter (Figure 5-4). See 
“Azimuth Balancing Method” on page 5-7 for details.

4. For None or Least Squares adjustment types, select the 
apriori values of error of linear and angular measurements 
(Figure 5-5). The None method is used only when solving a 
resection.

Figure 5-5. Assign Apriori Values for Least Squares Method

5. Click OK.

Set Refraction Coefficient
To correct the vertical angle for the earth’s curvature and the 
refraction in the atmosphere, select the TS-Computation tab on 
the Process properties dialog box and select the appropriate 
refraction coefficient (Figure 5-6).

Figure 5-6. Process Properties – TS-Computation
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Least Squares Method
The method of least squares provides the most rigorous 
adjustment:

• allows for variation in precision in the observations, 

• minimizes the random variations in the observations, 

• provides the best estimates for positions of all traverse 
stations, and 

• yields statistics relative to the accuracies of adjustment 
observations and positions. 

This method requires more of a computational effort than the 
approximate adjustment.

Compass Rule
The compass rule was developed for the second combination of 
precisions and observations, and can be shown to be rigorous 
when the angular precision equals the precision in linear 
distances condition is rigidly enforced.

With the compass rule, adjustments are applied to both latitudes 
and departures in proportion to the length of the lines. In other 
words, the longer a line, the greater are its latitude and 
departure adjustments (and vice versa), as shown in the 
following formulas:

This method works for closed traverses or traverses between 
two known points.

AdjustmentInLatitudeAB
LatitudeMisclosure

------------------------------------------------------------------ LengthOfAB
PerimeterOfTraverse
---------------------------------------------------------=

AdjustmentInDepartureAB
DepartureMisclosure

------------------------------------------------------------------------ LengthOfAB
PerimeterOfTraverse
---------------------------------------------------------=
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Transit Rule
The transit rule was developed for the first combination of 
precisions and observations.

With the transit rule, adjustments are applied to respective 
latitudes in proportion to their lengths; thus, the longer a 
latitude, the greater is its adjustment (and vice versa). Similarly, 
adjustments are applied to respective departures in proportion 
to their lengths. Adjustment can be computed using the 
following formulas:

This method works for closed traverses or traverses between 
two known points.

Crandall Method
The Crandall method is a rather complicated procedure that is 
more rigorous than either the compass or transit rule, requiring 
substantially more computations.

In the Crandall method of traverse adjustment, the angular error 
is equally distributed to all measured angles. The adjusted 
angles are then held fixed and all remaining corrections placed 
in the linear measurements through a weighted, least-squares 
procedure. The Crandall method is suitable for adjusting 
traverses where the linear measurements contain larger random 
errors than the angular measurements. 

Because of the angle balancing, this method works only for 
closed traverses or traverses where azimuths are known at 
beginning and ending point, plus beginning and ending points 
are known for allocating distance corrections.

AdjustmentInLatitudeAB
LatitudeMisclosure

------------------------------------------------------------------ LatitudeOfAB
AbsoluteSumOfLatitudes
-------------------------------------------------------------------=

AdjustmentInDepartureAB
DepartureMisclosure

------------------------------------------------------------------------ DepartureOfAB
AbsoluteSumOfDepartures
------------------------------------------------------------------------=
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Interior Angle Balancing Method
The Interior Angle Balancing method. The sum of all interior 
angles of a closed traverse (loop) should equal (n-2)* 180 
degrees. The discrepancy should be allocated equally to each 
interior angle. Clearly works only for closed traverses (loops).

Azimuth Balancing Method
The Azimuth Balancing method. Knowing azimuths at 
beginning and ending of traverse, calculate azimuth misclosure 
and distribute equally to all direction measurements. Works for 
open traverses.

User-defined Parameters
1. To change the information view of the opened file, click File-

>Job Configuration (Figure 5-7).

Figure 5-7. File->Job Configuration
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2. Click Display on the Job Configuration dialog box 
(Figure 5-8).

Figure 5-8. Job Configuration – Click Display

3. Edit the following parameters: 

• The Precisions tab (Figure 5-9) defines the number of 
digits after decimal.

Figure 5-9. Precisions Tab

• The Points tab (Figure 5-10) sets a coordinate type and a 
coordinate order.

Figure 5-10. Points Tab
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• The Angles tab (Figure 5-11) defines an angle 
representation.

Figure 5-11. Angles Tab

• The Strings tab (Figure 5-12) contains the field that 
switches on/off the output alphanumeric code describing 
surveying points on the screen.

Figure 5-12. Strings Tab

• The GPS Obs tab (Figure 5-13) defines how the baseline’s 
coordinates are represented.

Figure 5-13. GPS Obs tab
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• The TS Obs tab (Figure 5-14) defines the representation of 
the Total Station measurements.

Figure 5-14. TS Obs Tab

4. To view, add, or remove available geoid files, click Coordinate 
Systems in the Job Configuration dialog box (Figure 5-15).

Figure 5-15. Job Configuration – Coordinate Systems

5. To change autosave time intervals when editing a file, click 
Save in the Job Configuration dialog box and type the desired 
interval (Figure 5-16).

Figure 5-16. Job Configuration – Click Save and Set Backup Interval
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• Topcon Link automatically creates a reserve copy of the 
editing file after the expiration of the entered time interval.

After saving a file, Topcon Link automatically deletes the 
reserve copy.

• The default time interval is 10 minutes; the lowest time 
interval is 1 minute. To switch the autosaving off, type a 
“0” in the AutoSave Interval field. 

• If starting Topcon Link after an abnormal termination and 
the editing file was not saved, Topcon Link opens a reserve 
copy of the edited file and marks it as “Recovered”.

6. To change the type of adjustment click Process properties 
(Figure 5-17)

Figure 5-17. Job Configuration – Set Process Properties

Printing Files
To print a coordinates file, TS raw data file, or TopSURV file:

1. Open the desired file.

2. Click File->Print Setup and define the Printer Properties, 
Paper Size, and Orientation parameters.

3. On the file window, click the desired tab or a left/right panel.
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4. Click File->Print Preview. Check the file representation 
(Figure 5-18). Repeat steps 2 and 3 as needed.

Figure 5-18. Print Preview – Points Tab, TopSURV File

5. Click File->Print menu, click OK.
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Option Authorization 
File
A-1
Topcon Positioning Systems issues an Option Authorization File 
(OAF) to enable the specific options that customers purchase. An 
Option Authorization File allows customers to customize and 
configure the receiver according to particular needs, thus only 
purchasing those options needed. 

Typically, all receivers ship with a temporary OAF that allows the it 
to be used for a predetermined period of time. When the receiver is 
purchased, a new OAF permanently activates desired, purchased 
options. Receiver options remain intact when clearing the NVRAM 
or resetting the receiver.

The OAF enables the following kinds of functions. For a complete 
list of available options and details, visit the TPS website 
(www.topcongps.com/tech/index) or consult your TPS dealer.

• Type of signal (standard L1; 
optional L2)

• Memory (standard 0Mb; 
optional 1Mb up to 96Mb)

• Update rate standard 1Hz 
(optional 5, 10, or 20Hz)

• RTK at 1Hz, 5Hz, 10Hz, 
and 20Hz

• RTCM/CMR Input/Output

• Event marker

• Co-Op tracking

• Advanced multipath 
reduction

• Wide Area Augmentation 
System (WAAS)

• Receiver Autonomous 
Integrity Monitoring 
(RAIM)

• 1 PPS (Pulse-Per-Second; a 
timing signal)
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Notes:
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Cables/COM Ports
B-1
Serial Interface Cable
Serial interface cables connect the total station (TS) with an IBM 
PC compatible computer.

• F-4 cable (GTS – D-sub 9 pins). Table B-1 describes pin 
connections for the TS and computer (PC).

• F-3 cable (GTS – D-sub 25 pins). Table B-2 describes pin 
connections for the TS and computer (PC).

Table B-1. F-4 Cable

(GTS)    (PC)

GND (1) (5) GND

N.C. (2)

TXD (3) (3) RXD

RXD (4) (2) TXD

(RTS) (5) (8) CTS

N.C (6) (6) DSR

Table B-2. F-3 Cable

(GTS)    (PC)

GND (1) (1) FG

N.C. (2) (7) SG
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Parallel Interface Cable
The parallel interface cable connects a TS with a Centronics printer. 

B-2 Cable (GTS Parallel – centronics 1/F 38 pins). Table B-3 
describes pin connections for the total station and printer.

TXD (3) (3) RXD

RXD (4) (2) TXD

(RTS) (5) (5) CTS

N.C (6) (6) DSR

Table B-3. F-4 Cable

(GTS)    (Printer)

STROB (1) (1) STROB

BUSY (2) (11) INPUT-BUSY

D0 (3) (2) DATA1

D1 (4) (3) DATA2

D2 (5) (4) DATA3

D3 (6) (5) DATA4

D4 (7) (6) DATA5

D5 (8) (7) DATA6

D6 (9) (8) DATA7

D7 (10) (9) DATA8

GND (11) (14) GND

N.C. (12) (16) GND

Table B-2. F-3 Cable (Continued)

(GTS)    (PC)
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Serial C-RS232C Connector Definition

B-3
Serial C-RS232C Connector Definition
The RS232 cable connects the GNSS TPS receiver (ports A and D) 
with a computer. Figure B-1shows the pin locations for the 
receiver’s connector.

Figure B-1. RS232C Receiver Connector

Table B-4 gives RS232 connector pin details.

The RS232 connector types are sealed receptacle, 7 pin W.W. 
FISCHER, INC, p/n DBEU 102 A056. 

Table B-4. RS232 Connector Specifications

Number Signal Name Dir Details

1 Power_OUT P Power Output (I<0.2 A)

2 GND - Signal ground

3 CTS I Clear to send

4 RTS O Request to send

5 RXD I Receive data

6 TXD O Transmit data

7 Not used
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Table B-5 gives connection details for the receiver and cable.

Total Station COM Port Settings
The following RS-232-C interface options can be set in the 
GTS-600 series application program.

Baud Rate: 1200  /  2400  /  4800  /  9600  /  19200 baud

Parity: NONE  /  ODD  /  EVEN

Data Bits: 7  /  8

Stop Bits: 1  /  2

Protocol: ACK – NACK (Uploading in FC-5 format only) 

ONE WAY

The following RS-232-C interface options can be set in the GTS-
700 series application program.

Baud Rate: 300  /  1200  /  2400  /  4800  /  9600  /  19200

Parity: NONE  /  ODD  /  EVEN

Data Bits: 7  /  8

Stop Bits: 0  /  1  /  2         

Protocol: XON-XOFF

Table B-5. RS232 Connection Pin Details

TPS Receiver DB9 Female

1 -

2 5

3 7

4 8

5 3

6 2

7 1
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B-5
ACK – NACK (Uploading in FC-5 format only)

The following RS-232-C interface options can be set in the GTS-
800A series application program.

Baud Rate: 1200  /  2400  /  4800  /  9600 baud

Parity: NONE  /  ODD  /  EVEN

Data Bits: 7  /  8

Stop Bits: 1  /  2

Data Format: ASCII

Signal Control: RTS. Hi / Low

The following RS-232-C interface options can be set in the GTS-
2000 series application program.

Baud Rate: 300  /  600 / 1200  /  2400  /  4800  /  9600 baud

Parity: NONE  /  ODD  /  EVEN

Data Bits: 7  /  8

Stop Bits: 1  /  2         

Protocol: ACK – NACK (Uploading in FC-5 format only)

ONE WAY

The following RS-232-C interface options can be set in the 
AP-L1A series application program.

Bit Format: Selecting items Contents

D8 S1 NONE 8bit, stop 1, NONE 

D8 S2 NONE 8bit, stop 2, NONE

D7 S1 NONE 7bit, stop 1, NONE

D7 S2 NONE 7bit, stop 2, NONE
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D8 S1 EVEN 8bit, stop 1, EVEN 

D8 S2 EVEN 8bit, stop 2, EVEN 

D7 S1 EVEN 7bit, stop 1, EVEN 

D7 S2 EVEN 7bit, stop 2, EVEN 

D8 S1 ODD 8bit, stop 1, ODD 

D8 S2 ODD 8bit, stop 2, ODD

D7 S1 ODD 7bit, stop 1, ODD

D7 S2 ODD 7bit, stop 2, ODD

Trans speed in baud: COM1 COM2

38400

19200

9600 9600

4800 4800

2400 2400

1200 1200

Terminate: EXT, ETX+CR, ETX+CRLF

Protocol: (only for COM2)

Selecting items Contents

SERIAL Based on RS-232C (3

lines system)

MODEM Based on RS-232C.
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B-7
GNSS Receiver COM Port Settings
The following RS-232-C interface options are default 
communication settings for the GNSS receiver application 
program.

Port input mode: CMD for GRIL or Command for 
PC-CDU; the port is in command mode. 
In this mode the port recognizes the 
commands sent by the user.

Hardware handshaking: OFF

Serial port baud rate: 115200 baud

Stop bits: 1

Parity: N (no parity)

Data bits: 8 
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Sample File Formats
C-1
Coordinate File Formats
Topcon Link can send, receive, and convert a number of different 
data types. Formats of files that are ASCII are listed below. These 
sample files are used in the Topcon Link Reference Manual screen 
shots.

GTS-6 Points Coordinate Format
GTS-6 coordinate input and output has the same format.

Name, X(easting), Y(northing), Z(elevation)
_+1 _ x+00000009939_ y+00000013376_ z+00000001119

_+10 _ x+00000018482_ y+00000015981_ z+00000000022

_+11 _ x+00000015360_ y+00000016995_ z+00000000018

_+1113 _ x+00000013121_ y+00000012355_ z-00000001882

_+1114 _ x+00000010307_ y+00000013914_ z+00000000721

_+12 _ x+00000013520_ y+00000013371_ z+00000001000

_+2 _ x+00000003135_ y+00000015221_ z+00000004277

_+3 _ x+00000003993_ y+00000009992_ z-00000000096

_+4 _ x+00000006912_ y+00000007631_ z+00000000407

_+5 _ x+00000002577_ y+00000003569_ z+00000000788

_+6 _ x+00000012071_ y+00000003714_ z-00000000835

_+7 _ x+00000015842_ y+00000001442_ z+00000002275

_+8 _ x+00000021133_ y+00000002553_ z+00000000500

_+9 _ x+00000017531_ y+00000008498_ z-00000001320

_+MARK _ x+00000010000_ y+00000010000_ z+00000000500

_+MARK1 _ x+00000010033_ y+00000009975_ z-00000000959

_+MARK2 _ x+00000010006_ y+00000010001_ z-00000000904
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_+ST1 _ x+00000013856_ y+00000007047_ z-00000000258

_+ST1-1 _ x+00000013856_ y+00000007047_ z-00000000258

_+ST1-3 _ x+00000013830_ y+00000007105_ z-00000000927

_+ST2 _ x+00000014870_ y+00000010679_ z-00000000204

_+ST2-1 _ x+00000014874_ y+00000010625_ z-00000001005

_+ST2-2 _ x+00000014870_ y+00000010679_ z-00000000204_

GTS-7 Points Coordinate Format

Name, Easting, Northing, Elevation
1,13.37600,9.93900,1.11900,

2,15.22100,3.13500,4.27700,

3,9.99200,3.99300,-0.09600,

4,7.63100,6.91200,0.40700,

5,3.56900,2.57700,0.78800,

6,3.71400,12.07100,-0.83500,

7,1.44200,15.84200,2.27500,

8,2.55300,21.13300,0.50000,

9,8.49800,17.53100,-1.32000,

10,15.98100,18.48200,0.02200,

11,16.99500,15.36000,0.01800,

12,13.37100,13.52000,1.00000,

1113,12.35500,13.12100,-1.88200,

1114,13.91400,10.30700,0.72100,

MARK,10.00000,10.00000,0.50000,

MARK1,9.97500,10.03300,-0.95900,

MARK2,10.00100,10.00600,-0.90400,

ST1,7.04700,13.85600,-0.25800,

ST1-1,7.04700,13.85600,-0.25800,

ST1-3,7.10500,13.83000,-0.92700,

ST2,10.67900,14.87000,-0.20400,

ST2-1,10.62500,14.87400,-1.00500,

ST2-2,10.67900,14.87000,-0.20400,
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Name,E,N,Z,Code Coordinate Format
Name, Easting, Northing, Elevation, Code 
1,13.37600,9.93900,1.11900

2,15.22100,3.13500,4.27700

3,9.99200,3.99300,-0.09600

4,7.63100,6.91200,0.40700

5,3.56900,2.57700,0.78800

6,3.71400,12.07100,-0.83500

7,1.44200,15.84200,2.27500

8,2.55300,21.13300,0.50000

9,8.49800,17.53100,-1.32000

10,15.98100,18.48200,0.02200

11,16.99500,15.36000,0.01800

12,13.37100,13.52000,1.00000

1113,12.35500,13.12100,-1.88200

1114,13.91400,10.30700,0.72100

MARK,10.00000,10.00000,0.50000

MARK1,9.97500,10.03300,-0.95900

MARK2,10.00100,10.00600,-0.90400

ST1,7.04700,13.85600,-0.25800

ST1-1,7.04700,13.85600,-0.25800

ST1-3,7.10500,13.83000,-0.92700

ST2,10.67900,14.87000,-0.20400

ST2-1,10.62500,14.87400,-1.00500

ST2-2,10.67900,14.87000,-0.20400

Name,Lat,Lon,Ht,Code Coordinate Format
Name, Lat, Lon, Ht, Code
1,0°00'00.32"N,0°00'00.43"E,1.11900

2,0°00'00.10"N,0°00'00.49"E,4.27700

3,0°00'00.13"N,0°00'00.32"E,-0.09600

4,0°00'00.23"N,0°00'00.25"E,0.40700

5,0°00'00.08"N,0°00'00.12"E,0.78800

6,0°00'00.39"N,0°00'00.12"E,-0.83500

7,0°00'00.52"N,0°00'00.05"E,2.27500
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8,0°00'00.69"N,0°00'00.08"E,0.50000

9,0°00'00.57"N,0°00'00.28"E,-1.32000

10,0°00'00.60"N,0°00'00.52"E,0.02200

11,0°00'00.50"N,0°00'00.55"E,0.01800

12,0°00'00.44"N,0°00'00.43"E,1.00000

1113,0°00'00.43"N,0°00'00.40"E,-1.88200

1114,0°00'00.34"N,0°00'00.45"E,0.72100

MARK,0°00'00.33"N,0°00'00.32"E,0.50000

MARK1,0°00'00.33"N,0°00'00.32"E,-0.95900

MARK2,0°00'00.33"N,0°00'00.32"E,-0.90400

ST1,0°00'00.45"N,0°00'00.23"E,-0.25800

ST1-1,0°00'00.45"N,0°00'00.23"E,-0.25800

ST1-3,0°00'00.45"N,0°00'00.23"E,-0.92700

ST2,0°00'00.49"N,0°00'00.35"E,-0.20400

ST2-1,0°00'00.49"N,0°00'00.34"E,-1.00500

ST2-2,0°00'00.49"N,0°00'00.35"E,-0.20400

Name,N,E,Z,Code Coordinate Format
Name, N, E, Z, Code 
1,9.93900,13.37600,1.11900

2,3.13500,15.22100,4.27700

3,3.99300,9.99200,-0.09600

4,6.91200,7.63100,0.40700

5,2.57700,3.56900,0.78800

6,12.07100,3.71400,-0.83500

7,15.84200,1.44200,2.27500

8,21.13300,2.55300,0.50000

9,17.53100,8.49800,-1.32000

10,18.48200,15.98100,0.02200

11,15.36000,16.99500,0.01800

12,13.52000,13.37100,1.00000

1113,13.12100,12.35500,-1.88200

1114,10.30700,13.91400,0.72100

MARK,10.00000,10.00000,0.50000

MARK1,10.03300,9.97500,-0.95900
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MARK2,10.00600,10.00100,-0.90400

ST1,13.85600,7.04700,-0.25800

ST1-1,13.85600,7.04700,-0.25800

ST1-3,13.83000,7.10500,-0.92700

ST2,14.87000,10.67900,-0.20400

ST2-1,14.87400,10.62500,-1.00500

ST2-2,14.87000,10.67900,-0.20400

Raw Data File Formats

GTS-6 Raw Format
Refer to the GTS-6 interface manual for details.
_'MARK_(STAT_)1.52000_+ST1_ W+000049020m09757060-
03726440d+0000138560+0000070470-

0000002580***+0000+000000_*STAT_,1.60000_+ST1_ 
W+000049040m09757060-03726440d+0000138560+0000070470-
0000002580***+0000+000000_*STAT_,1.60000_+ST2_ 

W+000049560m09713460+00756170d+0000148700+0000106790-

0000002040***+0000+000000_*STAT_,1.60000_+ST2_ 
W+000049560m09713470+00756170d+0000148700+0000106790-
0000002040***+0000+000000_*STAT_,1.60000_+1_ 

?+00003448m0781803+0910223d+00003376***+00+00000_*TREE_,1.600
00_+2_ 
?+00009448m0655422+1424456d+00008625***+00+00000_*TREE_,1.600
00_+3_ ?+00006029m0945426-
1795529d+00006007***+00+00000_*TREE_,1.60000_+4_ 

?+00003892m0901125-
1423025d+00003892***+00+00000_*TREE_,1.60000_'ST1-
1_(STAT_)1.52000_+MARK1_ 
W+000048540m09720510+14233160d+0000100330+0000099750-
0000009590***+0000+000000_*STAT_,1.60000_+MARK1_ 
W+000048560m09720510+14233160d+0000100330+0000099750-
0000009590***+0000+000000_*STAT_,1.60000_+ST2-1_ 
W+000037800m10010080+07407150d+0000148740+0000106250-
0000010050***+0000+000000_*STAT_,1.60000_+ST2-1_ 
W+000037790m10010080+07407150d+0000148740+0000106250-
0000010050***+0000+000000_*STAT_,1.60000_+5_ 
?+00011857m0843301-
P/N 7010-0522 www.topconpositioning.com



Sample File Formats

C-6
1625151d+00011803***+00+00000_*TREE_,1.60000_+6_ 
?+00003813m0972903-
1181002d+00003781***+00+00000_*TREE_,1.60000_+7_ 
?+00006496m0661635-
0702932d+00005947***+00+00000_*TREE_,1.60000_+8_ 
?+00008594m0842419-
0314150d+00008553***+00+00000_*TREE_,1.60000_'ST2-
2_(STAT_)1.52000_+MARK2_ W+000049500m09711260-
17203440d+0000100060+0000100010-
0000009040***+0000+000000_*STAT_,1.60000_+MARK2_ 
W+000049500m09711250-17203440d+0000100060+0000100010-
0000009040***+0000+000000_*STAT_,1.60000_+ST1-3_ 
W+000037770m09947420-10613530d+0000138300+0000071050-
0000009270***+0000+000000_*STAT_,1.60000_+ST1-3_ 
W+000037770m09947410-10613530d+0000138300+0000071050-
0000009270***+0000+000000_*STAT_,1.60000_+9_ 
?+00003593m1064517-
0392059d+00003441***+00+00000_*TREE_,1.60000_+10_ 
?+00006422m0871605+0554414d+00006415***+00+00000_*TREE_,1.600
00_+11_ 
?+00006342m0871605+0853339d+00006335***+00+00000_*TREE_,1.600
00_+12_ 
?+00003273m0665438+1163803d+00003011***+00+00000_*TREE_,1.600
00_+13_ 
?+00002902m1232505+1361343d+00002422***+00+00000_*TREE_,1.600
00_+14_ 
?+00005683m0794856+1444001d+00005594***+00+00000_*TREE_,1.600
00_

GTS-7 Raw Format
The general format for each record is:

CONTROL WORD    field1,…….,fieldn

JOB job name, description

DATE date, name

NAME surveyors name

INST instrument id

UNITS Meter/Feet, Degree/Gon

SCALE grid factor,scale factor,elevation
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ATMOS temp,press

STN ptno, ins ht, stn id

XYZ X(easting), Y(northing), Z(elevation)

BKB ptno, backsight bearing, backsight angle

BS ptno[,target height]

FS ptno,target height, pt code[,string number]

SS ptno,target height, pt code[,string number]

CTL control code[,pt code 2[,string no 2]](optional)

HV HA, VA

SD HA, VA, SD

HD HA, HD, VD

OFFSET - radial offset, tangential offset, vertical offset

NOTE comments

XYZ if present follows the STN record

BKB if present follows the BKB record or STN record if no BKB

CTL if present follows the FS or SS header record

HV,SD,orHD - must follow a BS, FS, or SS header and follows the CTL if 
present

OFFSET - may follow any SD or HD record

TTools v1.0

JOB C:\Download\777.raw,Comment

NAME TopconTools

INST TS

UNITS M,D

SCALE 1.000000,1.000000,0.000000

DATE 00/00/00,00:00

TEMP 0.000,000

STN MARK,1.52000,STAT

BKB ST1,0.0000,322.33160

XYZ 13.85600,7.04700,-0.25800

BS ST1,1.60000

SD -37.26440,97.57060,4.90200

SS ST1,1.60000,STAT

SD -37.26440,97.57060,4.90400
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Sample File Formats
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XYZ 13.85600,7.04700,-0.25800

SS ST2,1.60000,STAT

SD 7.56170,97.13460,4.95600

XYZ 14.87000,10.67900,-0.20400

SS ST2,1.60000,STAT

SD 7.56170,97.13470,4.95600

XYZ 14.87000,10.67900,-0.20400

SS 1,1.60000,TREE

SD 91.02230,78.18030,3.44800

SS 2,1.60000,TREE

SD 142.44560,65.54220,9.44800

SS 3,1.60000,TREE

SD -179.55290,94.54260,6.02900

SS 4,1.60000,TREE

SD -142.30250,90.11250,3.89200

STN ST1-1,1.52000,STAT

BKB MARK1,0.0000,142.33160

XYZ 10.03300,9.97500,-0.95900

BS MARK1,1.60000

SD 142.33160,97.20510,4.85400
SS MARK1,1.60000,STAT

SD 142.33160,97.20510,4.85600

XYZ 10.03300,9.97500,-0.95900

SS ST2-1,1.60000,STAT

SD 74.07150,100.10080,3.78000

XYZ 14.87400,10.62500,-1.00500

SS ST2-1,1.60000,STAT

SD 74.07150,100.10080,3.77900

XYZ 14.87400,10.62500,-1.00500

SS 5,1.60000,TREE

SD -162.51510,84.33010,11.85700

SS 6,1.60000,TREE

SD -118.10020,97.29030,3.81300

SS 7,1.60000,TREE

SD -70.29320,66.16350,6.49600

SS 8,1.60000,TREE
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Raw Data File Formats
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SD -31.41500,84.24190,8.59400

STN ST2-2,1.52000,STAT

BKB MARK2,0.0000,187.56160

XYZ 10.00600,10.00100,-0.90400

BS MARK2,1.60000

SD -172.03440,97.11260,4.95000

SS MARK2,1.60000,STAT

SD -172.03440,97.11250,4.95000

XYZ 10.00600,10.00100,-0.90400

SS ST1-3,1.60000,STAT

SD -106.13530,99.47420,3.77700

XYZ 13.83000,7.10500,-0.92700

SS ST1-3,1.60000,STAT

SD -106.13530,99.47410,3.77700

XYZ 13.83000,7.10500,-0.92700

SS 9,1.60000,TREE

SD -39.20590,106.45170,3.59300

SS 10,1.60000,TREE

SD 55.44140,87.16050,6.42200

SS 11,1.60000,TREE

SD 85.33390,87.16050,6.34200

SS 12,1.60000,TREE

SD 116.38030,66.54380,3.27300

SS 13,1.60000,TREE

SD 136.13430,123.25050,2.90200

SS 14,1.60000,TREE

SD 144.40010,79.48560,5.68300

GTS-7+ Raw Format
The GTS-7+ format is similar the GTS-7 format, but also saves 
measured points SideShots coordinates after calculating 
coordinates in Topcon Link.
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TOPCON XML File Format
<?xml version="1.0"?>

<data>

<Point>

<PointNumber>1</PointNumber><Code>TREE</Code></Point><Point>

<PointNumber>2</PointNumber><Code>TREE</Code></Point><Point>

<PointNumber>3</PointNumber><Code>TREE</Code></Point><Point>

<PointNumber>4</PointNumber><Code>TREE</Code></Point><Point>

<PointNumber>5</PointNumber><Code>TREE</Code></Point><Point>

<PointNumber>6</PointNumber><Code>TREE</Code></Point><Point>

<PointNumber>7</PointNumber><Code>TREE</Code></Point><Point>

<PointNumber>8</PointNumber><Code>TREE</Code></Point><Point>

<PointNumber>9</PointNumber><Code>TREE</Code></Point><Point>

<PointNumber>10</PointNumber><Code>TREE</Code></Point><Point>

<PointNumber>11</PointNumber><Code>TREE</Code></Point><Point>

<PointNumber>12</PointNumber><Code>TREE</Code></Point><Point>

<PointNumber>13</PointNumber><Code>TREE</Code></Point><Point>

<PointNumber>14</PointNumber><Code>TREE</Code></Point><Point>

<PointNumber>MARK</PointNumber><Code>STAT</Code></Point><Point>

<PointNumber>MARK1</PointNumber><Code>STAT</
Code><Northing>32.91667</Northing><Easting>32.72638</Easting><Height>-
3.14633</Height></Point><Point>

<PointNumber>MARK2</PointNumber><Code>STAT</
Code><Northing>32.82808</Northing><Easting>32.81168</Easting><Height>-
2.96588</Height></Point><Point>

<PointNumber>ST1</PointNumber><Code>STAT</
Code><Northing>45.45932</Northing><Easting>23.12008</Easting><Height>-
0.84646</Height></Point><Point>

<PointNumber>ST1-1</PointNumber><Code>STAT</Code></Point><Point>

<PointNumber>ST1-3</PointNumber><Code>STAT</
Code><Northing>45.37402</Northing><Easting>23.31037</Easting><Height>-
3.04134</Height></Point><Point>

<PointNumber>ST2</PointNumber><Code>STAT</
Code><Northing>48.78609</Northing><Easting>35.03609</Easting><Height>-
0.66929</Height></Point><Point>
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<PointNumber>ST2-1</PointNumber><Code>STAT</
Code><Northing>48.79921</Northing><Easting>34.85892</Easting><Height>-
3.29724</Height></Point><Point>

<PointNumber>ST2-2</PointNumber><Code>STAT</Code></Point><Project>

<JobName>C:\Download\x2.xml</JobName><DistanceUnitIndicator>Feet</
DistanceUnitIndicator><AngleUnitIndicator>DMS</
AngleUnitIndicator><GridFactor>1.000000</GridFactor><Scale>1.000000</
Scale><Elevation>0.000000</Elevation></Project><Station>

<StationPoint>MARK</StationPoint><StationCode>STAT</
StationCode><InstrumentHeight>4.98688</InstrumentHeight><Observation>

<AngleUnitIndicator>DMS</AngleUnitIndicator><DistanceUnitIndicator>Feet</
DistanceUnitIndicator><PointNumber>ST1</PointNumber><Code1>STAT</
Code1><ObsType>Backsight</ObsType><PrismHeight>5.24934</
PrismHeight><HorizontalAngle>-37.26440</
HorizontalAngle><SlopeDistance>16.08268</
SlopeDistance><HorizontalDistance>15.92848</
HorizontalDistance><VerticalAngle>97.57060</
VerticalAngle><VerticalDistance>-2.22484</
VerticalDistance><Northing>45.45932</Northing><Easting>23.12008</
Easting><Height>-0.84646</Height></Observation><BacksightPoint>

<PointNumber>ST1</PointNumber><BacksightBearing>0.0000</
BacksightBearing><Code1>STAT</Code1><BacksightAngle>322.33160</
BacksightAngle><Northing>45.45932</Northing><Easting>23.12008</
Easting><Height>-0.84646</Height></BacksightPoint><Observation>

<AngleUnitIndicator>DMS</AngleUnitIndicator><DistanceUnitIndicator>Feet</
DistanceUnitIndicator><PointNumber>14</PointNumber><Code1>TREE</
Code1><ObsType>Shotsight</ObsType><PrismHeight>5.24934</
PrismHeight><HorizontalAngle>144.40010</
HorizontalAngle><SlopeDistance>18.64501</
SlopeDistance><HorizontalDistance>18.35302</
HorizontalDistance><VerticalAngle>79.48560</
VerticalAngle><VerticalDistance>3.29677</VerticalDistance></Observation></
Station></data>
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DXF Format
0

SECTION

  2

9

$CECOLOR

 62

0

  9

$EXTMIN

 10

0.3245

 20

0.3245

  9

$EXTMAX

 10

0.3245

 20

0.3245

  9

$LIMMIN

 10

7.0470

 20

10.0060

  9

$LIMMAX

 10

11.1658

 20

15.0363

  0

ENDSEC

  0
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1_point_names

 70

0

  6

DASHED

 62

255

  0

LAYER

  2

2_comment

 70

0

  6

DASHED1

 62

5

  0

ENDTAB

  0

ENDSEC

  0

SECTION

BLOCKS

  0

BLOCK

  8

0

  2

MARK1

 70

2

 10

9.9750

 20

10.0330
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 30

-0.9590

  0

POINT

  8

0

 10

9.9750

 20

10.0330

 30

-0.9590

  0

ATTDEF

  8

SEQEND

  0

INSERT

  8

0

 66

1

  2

ST2-1

 10

10.6250

 20

14.8740

 30

-1.0050

  0

SEQEND

  0

ENDSEC

  0

EOF
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LandXML File Format
<?xml version=”1.0”?>

<LandXML xmlns=”http://www.landxml.org/schema/LandXML-1.0” 
xmlns:xsi=”http://www.w3.org/2001/XMLSchema-instance” 
xsi:schemaLocation=”http://www.landxml.org/schema/LandXML-1.0 http://
www.landxml.org/schema/LandXML-1.0/LandXML-1.0.xsd” version=”1.0” 
date=”10/24/2003” time=”20:30:47” readOnly=”false” language=”English”>

<Project name=””/>

<Units>

<Metric linearUnit=”meter” areaUnit=”squareMeter” volumeUnit=”cubicMeter” 
temperatureUnit=”celsius” pressureUnit=”mmHG” angularUnit=”decimal 
degrees” directionUnit=”decimal degrees”/>

</Units>

<Application name=”TopSurv” manufacturer=”Topcon” version=”1.10” 
desc=”OnBoard Version” manufacturerURL=”www.topcon.com”/>

<CgPoints>

<CgPoint name=”0”>9807019.29622078 973450.31989092 213.271773</
CgPoint>

<CgPoint name=”Auto1”>9806910.67604002 973580.14059322 217.066318</
CgPoint>

<CgPoint name=”Auto2”>9806910.65496200 973580.16603014 217.072248</
CgPoint>

<CgPoint name=”Auto3”>9806910.67343960 973580.14156662 217.069849</
CgPoint>

<CgPoint name=”Topo1”>9806910.66581991 973580.14734168 217.080830</
CgPoint>

<CgPoint name=”Topo2”>9806910.66050706 973580.15343608 217.075792</
CgPoint>

<CgPoint name=”Topo3”>9806910.65094054 973580.16451221 217.072649</
CgPoint>

</CgPoints>

</LandXML>
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GPS Vector File Format
GPS Vector files have the following format:

Header

VPP(for vector),Name_Point1,Name_Point2, 
dX,dY,dZ,sigma_dX,sigma_dY,sigma_dZ, Y(northing), 
Z(elevation),cor_XY,cor_XZ,cor_YZ,noteP(for 
point),Nane_Point,Lat(DD MM SS.ss),Lon(DD MM 
SS.ss),Ell.Height

//TopconVectorFormat:v.1,

VPP,s0_8OW0,s2_8HDS,0.499,-1.692,
-0.949,0.002,0.001,0.002,0.763,0.748,0.825

VPP,s0_8OW0,s1_416O,-2.126,0.769,-0.597,0.002,0.003,0.004,0.450,0.319,0.573

VPP,s1_416O,s2_8HDS,2.683,-2.418,-0.296,0.005,0.005,0.006,0.510,0.482,0.652

VPP,master_8BGG,s0_8OW0,2.489,2.791,
-3.170,0.003,0.005,0.006,0.436,0.099,0.571

VPP,master_8BGG,s1_416O,0.327,3.540,
-3.788,0.003,0.004,0.007,0.457,0.258,0.602

VPP,master_8BGG,s2_8HDS,2.982,1.087,
-4.134,0.003,0.002,0.003,0.764,0.725,0.829

P,master_8BGG,55 33 44.000N,37 55 40.000E,506.774,

P,s0_8OW0,55 33 44.444N,37 58 40.888E,504.980,

P,s1_416O,55 33 44.666N,37 58 40.999E,501.043,

P,s2_8HDS,55 33 44.555N,37 58 40.777E,501.204,
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Printed File Formats
Topcon Link can print coordinate or Total Station raw data, as well 
as TopSURV files.

• Coordinate file (Figure C-1): 

Figure C-1. Sample Printed Coordinate File Format

• Total Station raw data file with the Points tab selected 
(Figure C-2):

Figure C-2. Sample Printed TS Raw Data File Format – Points Tab
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Sample File Formats
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•  Total Station raw data file with the TS Obs tab selected and the 
left panel is active (Figure C-3):

Figure C-3. Sample Printed TS Raw Data File – TS Obs Tab, Left Panel

• Total Station raw data file with the TS Obs tab selected and the 
right panel is active (Figure C-4):

Figure C-4. Sample Printed TS Raw Data File – TS Obs Tab, Right Panel

• TopSURV data file with the Points tab selected (Figure C-5):

Figure C-5. Sample Printed TopSURV File – Points Tab
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• TopSURV data file with the GPS Occupations tab selected 
(Figure C-6):

Figure C-6. Sample Printed TopSURV File – GPS Occupations Tab

• TopSURV data file with the TS Obs tab selected and the left 
panel is active (Figure C-7):

Figure C-7. Sample Printed TopSURV File – TS Obs Tab, Left Panel

• TopSURV data file with the TS Obs tab selected and the right 
panel is active (Figure C-8):

Figure C-8. Sample Printed TopSURV File – TS Obs Tab, Right Panel
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• TopSURV data file with the GPS Obs tab selected (Figure C-9):

Figure C-9. Sample Printed TopSURV File – GPS Obs Tab

• TopSURV data file with the Codes tab selected (Figure C-10):

Figure C-10. Sample Printed TopSURV File – Codes Tab
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1-8
Index
Index
A
ActiveSync 2-6–2-10, 2-21

settings
one COM port 2-8
two COM ports 2-9

starting 2-6
Add new device 2-3
Adjustment 5-2–5-7

 See also Methods of adjustment
network 5-2
traverse 5-2
type 5-3

Angle balance method 5-7
Antenna properties 4-36
Arrange window 1-8
Azimuth balance method 5-7

C
Cable

See also Serial cables
parallel interface B-2

Codes
See also Edit, codes
add 4-34
edit 4-39–4-40
tab 4-13

Compass rule 5-5
Compute coordinates 5-1

See also Process
Controller

export files to 2-21–2-22
import files 2-6–2-11

Convert files 3-3–3-6
coordinate files 3-6–3-11
GNSS raw data file 3-20
GPS+ raw data file 3-20
Topcon XML files 3-15–3-18
TopSURV files 3-12
TS raw data files 3-12–3-15

Convert files from 3-1
coordinate file 3-6
GPS+ raw data files 3-20
Topcon XML 3-15
TopSURV files 3-12
TS raw data files 3-12

Convert files to 3-2
FC-5 points 3-11
feature format 3-28
Geoid format 3-26
GIS format 3-21–3-23
GNSS raw data file 3-24
GPS vector file 3-28
GPS+ raw data file 3-24
GTS points 3-11
LandXML 3-18–3-20
RINEX 3-24
TDS format 3-25–3-26
Topcon geoid format 3-27
TPD file 3-24

Coordinate computation 5-1
Coordinates, edit 4-33
Crandal method 5-6
Custom formats 4-4
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Index

Index
D
Device

add 2-3
properties 2-3, 2-4, 2-12–2-13

E
Edit

antenna 4-36
CAD 4-23
code 4-30
codes 4-23, 4-34, 4-39
coordinate

files 4-20–4-23
order 4-22
points 4-22

coordinates 4-33
GPS Obs options 4-38
instrument 4-25, 4-31
job configuration 4-30
menu 1-7
multiple points 4-31
note 4-21
offsets 4-27, 4-36
point name 4-21, 4-25, 4-33, 

4-35
point to 4-26
reflector properties 4-26
string properties 4-28
TopSURV files 4-31–4-40
TS Obs 4-37
TS Obs options 4-29
TS raw data files 4-23–4-31

Export files 2-19
formats 2-21
instructions 2-15, 2-18
OAF 2-19
to device 2-15–2-22
to Total Station 2-16–2-18
to TPS Controller 2-21–2-22

F
Feature file format 3-28
File 1-6

formats 2-21, 4-1
menu 1-6
open 4-1–4-3
open user-defined 4-4–4-5
properties 4-16–4-17
save as 4-19
symbols 4-7, 4-9, 4-14

Formats 2-21, 4-1
coordinate C-1–C-4
custom 4-4
DXF C-12
GIS 3-21
GTS-6 C-1, C-5
GTS-7 C-2, C-6
GTS-7+ C-9
name,E,N,Z,code C-3
name,Lat,Lon,Ht,code C-3
printed files C-17–C-20
raw data C-5–C-9
TDS 3-25
user-defined 4-4
XML C-10

G
Geoid format, convert to 3-26
Geoid model

add 3-7–3-8, 3-22
select 3-8, 3-23

GIS file formats 3-21
GNSS receiver COM port status B-7
GPS Obs

tab 4-12
GPS Occupations tab 4-10
GPS vector file 3-28
Grid to ground parameters 3-11
GTS-6

coordinate format C-1
raw format C-5
Topcon Topcon Link Reference Manual



Index

Index
GTS-7
coordinate format C-2
raw format C-6

H
Help menu 1-8

I
Import files

from device 2-1–2-14
from Total Station 2-12–2-14
from TPS controller 2-6–2-11
from TPS receiver 2-4–2-6

Install
ActiveSync 2-6
Topcon Link 1-2–1-4

J
Job configuration 5-7

L
LandXML format 3-18
Least-squares method 5-5

M
Menu bar 1-5, 1-6–1-8
Methods of adjustment 5-5–5-7

N
Name,E,N,Z,Code coordinate format 

C-3
Name,Lat,Lon,Ht,Code coordinate 

format C-3
Name,N,E,Z,Code coordinate format 

C-4

Network adjustment 5-2

O
OAF A-1
OAFs A-1
Offsets, edit 4-27, 4-36
Open job 1-9
Orthometric height 3-7, 3-22

P
Parameters

ASCII/TSV files 3-9
communication 2-4
custom text files 3-9
GLONASS 3-24
grid to ground 3-11
job configuration 5-7
L1/L2 3-24
name,lat,lon,ht 3-10
other coordinate files 3-10
RINEX 3-24
user-defined 5-7

Point limits 3-27
Points

process 5-1, 5-1–5-2, 5-3–5-4
properties 4-21, 4-22, 4-23

Points tab
coordinate file 4-6
TopSURV file 4-10
TS file 4-7

Print
formats C-17–C-20
setup 5-11

Process 5-1–5-4
menu 1-7
properties 5-3

Properties
custom format 4-4
device 2-3
file 4-16–4-17
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Index

Index
process 5-3

R
Receiver

add device 2-3
connect with computer 2-9
export files to 2-19–2-20
import files 2-4–2-6

Refraction coefficient 5-4

S
Save files 1-9, 4-17–4-19

to current file/format 4-17
to different file 4-19
to different format 4-18

Serial cables
C-RS232C B-3

receiver settings B-7
TS settings B-4–B-6

interface B-1
Settings

ActiveSync 2-8–2-10
apriori values 5-4

Shortcuts 1-4, 1-5
Status bar 1-5
Symbols 4-7, 4-9, 4-14

T
TDS file formats 3-25
Toolbar 1-5, 1-9–1-10
Topcon geoid format, convert to 3-

27
Topcon XML file format C-10
TopSURV files 3-12
Total Station

COM port status B-4–B-6
export files to 2-16–2-18
export instructions 2-18
import files 2-12–2-14

import instructions 2-13
TPS Controller

See  Controller
TPS Receiver

See Receiver
Transit rule 5-6
Traverse adjustment 5-2
TS Obs tab 4-8–4-9, 4-11–4-12

U
User-defined format 4-4

V
View 1-7

coordinate file 4-6
file properties 4-16–4-17
menu 1-7
point observations 4-38
TopSURV files 4-10
TS raw data file 4-7

W
Window menu 1-8
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